Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

01 ram 1500, P0601 code, replaced ecm, still won't start and same code - help!

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-21-2013, 12:44 PM
GeorgiaberryMobley GeorgiaberryMobley is offline
Registered User
 
Join Date: Jun 2013
Posts: 9
Default 01 ram 1500, P0601 code, replaced ecm, still won't start and same code - help!

Our truck is a 2001 ram 1500, automatic transmission, v6 engine.

It is an annoying vehicle, but it is our only truck and we need it for work so I try to be patient with it LOL. A couple weeks ago, we started it, it drove about 4 feet and died and never would start again. Tried to turn over but wouldn't start.

We changed spark plugs (and some coil had been changed previously) and lo and behold it started right up. Ran for about 4 miles and died. Just like before, would not start, tried to turn over but just wouldn't start. Brother in law has code reader, and it had P0601 code. Replace computer.

OK - so I finally ended up ordering a reprogrammed replacement unit from Imperial Car Computer exchange - helpful guy on the phone but very very slow shipping OMG!!!! - ordered on tues - finally received part the FOLLOWING thursday (yesterday) ugh. Ridiculous with $20 for priority shipping.

We followed instructions and installed part - no change. Same not starting. Exactly the same. Same code.

What next? Phone help from imperial said "could be so many things... wiring issue, bad battery connection, corrosion in cables..." and that we could send them both units (theirs and our old computer) and they would compare programming to see if that told them anything. I am not eager to do that since their shipping is so poor.

Any suggestions? Thanks for your help. I really need it!

Georgiaberry
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 06-21-2013, 12:46 PM
GeorgiaberryMobley GeorgiaberryMobley is offline
Registered User
 
Join Date: Jun 2013
Posts: 9
Default

btw I have already scoured the local junkyards and had friends in other places looking as well for a cheaper replacement ecm/pcm and there are none to be found here....
Reply With Quote
  #3  
Old 06-21-2013, 01:17 PM
merc225hp's Avatar
merc225hp merc225hp is offline
Champion
 
Join Date: Oct 2009
Vehicle: 1996 Ram 1500 4wd
Location: Canada
Posts: 4,495
Default

I am not sure but this might be the place that has a horrendous rep for sending out dead pcm's, others will post up. Get your money back fast and then start hunting elsewhere. DO NOT send them your pcm!!! you might never see it again. Post the pcm part number you are looking for.

Edit: Check out B&G for new/used pcm's

Here is /was a link seems there site is under construction. http://www.bgchrysler.com/

B&G Chrysler Specialists, Inc
25180 Ryan Rd, Warren, MI 48091, United States
Phone:+1 586-758-2003
Hours:
Sunday Closed
Monday 8:00 am – 6:00 pm
Tuesday 8:00 am – 6:00 pm
Wednesday 8:00 am – 6:00 pm
Thursday 8:00 am – 6:00 pm
Friday 8:00 am – 5:00 pm
Saturday Closed
__________________

1996 1500, Built 5.9, 7" suspension lift, Dana 60's,241DLD xcase, xcase indexing ring, long-arms. DF May 2013 ROTM, DF photo of the week Oct/11/2013. RF TOTM July 2014.

Last edited by merc225hp; 06-21-2013 at 01:28 PM..
Reply With Quote
  #4  
Old 06-21-2013, 01:59 PM
GeorgiaberryMobley GeorgiaberryMobley is offline
Registered User
 
Join Date: Jun 2013
Posts: 9
Default

thank you - I don't think this is the awful place, I read about that place on the forum, I think it is auto parts exchange - I think we had also called that awful place but they sounded flaky and we ordered from this Imperial Car Computer Exchange in North Carolina.

the module # is P56040264AF

Wow - I have learned a lot from reading through the forum after searching for other posts about this error code. Wish I would have done that before I ordered but I was just overwhelmed and could not figure out the problem. I had an idea for some reason that this was a part that I could only get from a dealer and so I never called my local auto zone ... turns out they can order the part - have a reprogrammed unit to me the next day, for about $60 less. Ugh.

And I am gathering from the forum that sometimes people have to try 4 or 5 different reprogrammed units before they get a good one. So frustrating. So since last night I have been thinking that we have a problem that is shorting out the new computer, but maybe the new computer is just not any good.

I can't bear to deal with the wait from this place in NC. If we can't track down any other problem this weekend I am going to order from autozone and see if that part works, then try to get a refund from the place in NC, I guess.

So - do I have this right? Once the computer throws the P0601 code, all you can do is replace the computer. Even if there is a short or some corrosion or a bad ground that affected the computer and you fix that, the computer won't just magically go back to normal. It has to be replaced? Do I grasp the situation?
Reply With Quote
  #5  
Old 06-21-2013, 03:00 PM
merc225hp's Avatar
merc225hp merc225hp is offline
Champion
 
Join Date: Oct 2009
Vehicle: 1996 Ram 1500 4wd
Location: Canada
Posts: 4,495
Default

This might help you in your hunt,any of these pcm part numbers will work for your truck.

56040264AA
56040264AB
56040264AC
56040264AD
56040264AE
56040264AF

Latest version is 56040264AG
__________________

1996 1500, Built 5.9, 7" suspension lift, Dana 60's,241DLD xcase, xcase indexing ring, long-arms. DF May 2013 ROTM, DF photo of the week Oct/11/2013. RF TOTM July 2014.
Reply With Quote
  #6  
Old 06-21-2013, 04:15 PM
GeorgiaberryMobley GeorgiaberryMobley is offline
Registered User
 
Join Date: Jun 2013
Posts: 9
Default

oh gosh - thank you. that is good to know.
Reply With Quote
  #7  
Old 06-21-2013, 04:28 PM
gdstock's Avatar
gdstock gdstock is offline
Legend
 
Join Date: Jul 2011
Vehicle: 1999 Ram 1500, 5.2L auto
Location: Austin, TX
Posts: 8,257
Default

Check all the grounds. Battery to engine, battery to fender, battery to frame, engine block (rear passenger side) to firewall. Make sure PCM is tight and no corrosion around it.

Check connectors and make sure they acre clean and tight. Check connector on CTM.

Missing connection to PCM can fool it to think it is bad.
__________________
Ram 1500, 5.2L, 2wd, hardened trans with Derale pan, Hayden trans cooler, kegger mod, SCT tuned. New metallic black paint, TCP e-fans, HS 1.7 Rockers, restored interior.
Reply With Quote
  #8  
Old 06-21-2013, 06:24 PM
GeorgiaberryMobley GeorgiaberryMobley is offline
Registered User
 
Join Date: Jun 2013
Posts: 9
Default

ok thank you - I will pass that on to my hubby and b-i-l. I know we did all the cleaning etc of battery cables and so forth that the instructions said to do but I don't know about all those grounds.

good place to start. thanks!
Reply With Quote
  #9  
Old 06-21-2013, 07:45 PM
generaljr's Avatar
generaljr generaljr is offline
Professional
 
Join Date: Apr 2011
Vehicle: lifted 2wd Ion alloys, projectors,ram air hood, steering rack custom grille-bumper
Location: cuyama CA
Posts: 200
Default

maybe this can help, a friend of mine has a 2002 ram 1500 5.9, he had the check engine light on, we found the code for a bad PCM or ECM, not sure but what was the code, he didn't let me to try to fix his truck, he went to the dealer and bought a remanufactured one for $800+ instaled and reprogramed in his truck, it fixed the issues for a few weeks and suddenly began with multiple malfunctions NO BUS, intermittent stall-no start, faulty cluster lights, no turn signals, brake lights, well everything was weird at times, then he came asking for help at 9:00pm because of headlights acting weird, asked him what he did to the truck other than the ecm or pcm (Don't care) replacement, well the first symptoms began when he had somebody installing aftermarket audio-video system, Checked computer connections, grouns,battery and all were good, then moved to the audio system, pulled the dash to take a look at the cd player wiring and disconected the harness and kaboom all the warning lights went away, after inspecting the wires one at a time found that the illumination (Brown) wire was causing all the issues,just disconnected that one and everything is working as it should
__________________
Reply With Quote
  #10  
Old 06-22-2013, 04:15 PM
GeorgiaberryMobley GeorgiaberryMobley is offline
Registered User
 
Join Date: Jun 2013
Posts: 9
Default

Wow. I fear it is going to be some kind of problem like that. We haven't installed anything new like your friend did, but it seems like signs point to electrical issue and that is not good news to me, because I don't have anyone patient enough to check everything, and paying a mechanic for electrical work is $$$ because it takes so long to do all the checking.

We have historically had battery problems with this truck - not battery, I guess, but connection. Had to replace ends on both battery cables recently - that is a new thing we did?! and we always have corrosion build up on terminals - builds up so fast - has to be cleaned every couple of weeks it seems like or it gets to the point that the truck won't start. Battery always checks out ok at auto zone battery check.

Also replaced spark plugs day before this happened - and coil a few months ago. That's really all we have done. Before replacing coil the truck had been decelerating/shuddering when we were driving, like on the interstate. That problem seems to be fixed. Just reporting because I don't know enough to know if any of it matters...

Thanks for sharing that story, General - all these replies are getting me headed in the right direction I think.
Reply With Quote
Old 06-22-2013, 04:15 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 01:07 PM.

Internet Brands, Inc.


Contact Details & Emails