Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 3rd Gen Ram Tech
Sign in using an external account
Register Forgot Password?


3rd Gen Ram Tech 2002-2008 Rams: This section is for TECHNICAL discussions only, that involve the 2002 through 2008 Rams Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

08 3.7 Headproblems? waterpump?

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-11-2013, 10:14 PM
08RecordRam 08RecordRam is offline
Amateur
Garage is empty, add now
 
Join Date: Dec 2010
Vehicle: 08 ram 1500
Location: Greenville/Celeste Texas
Posts: 28
Default 08 3.7 Headproblems? waterpump?

So I got an 08 ram with 280k miles
Never had too many problems with it waterpump, wheel hubs, fuel pump
ANd the other parts from when it was stolen, hit a cow, deer, pigs, signs, trees and you name it whatever else.

So My truck has been overheating the last few days.
Poped the hood noticed fluid was low but full in rad looked around.
Thermostat house bolt was missing got a new one and changed thermostat.
I put new thermostat in just how the old one came out with the hole up top also.

As far as the waterpump I changed it last summer but Iam not sure if its working Since both the lower and upper rad hoses feel cold, but there are 2 3/8 hoses above the rad hose that goes to the thermostat that are hot to the touch.

When the truck gets to the running temp which takes about 10 mins. The oil light blinks when i take off from a stop and the engine sounds like a diesel when i take off. Iam not sure if its bc I didnt change the oil for 19K miles or what. But I did changed it before this started happening. Ive check it again and its doesnt give a milky apperance or anything.

The exhuast it puts out a mild steam that dissapers after it gets to the back of the truck. Drips enough I could fill up a cup in a few minutes.
(Ive got 2 6 inch tips dumped under the truck right behind the cab)
I cant notice a smell bc of my profession on the oil rigs and iam a heavy smoker.
Nor can I tell if its normal bc I havent had exhuast for 2 years I barley got true duals last week after getting my 7th inspection ticket and threatened to have my truck impounded by a judge!

The heater in my truck also stopped working a about 20 miles ago 30 miles total since it started overheating.

Can any of you nice folks in ram land suggest where I should go from here how to tell if its my waterpump, or something in my engine?

Also Ive probley had 3 different types of collents in my truck in the last 6k miles 2 different oil places universal, green I put in and about 1/3 of a gallon of red, and the yellow I put in it half gallon when i changed the thermostat.

I think I could fix it if its the engine but I dunno if the price of rebuilding the engine would be the same as getting a crate motor or something from craigslist and just using all my parts I got now, for the same price.
IVe never torn into an engine but I am a master plumber and have a high mechanicaly apatitude But I couldent tell you what a cam or a head or valve or any of that otherstuff is.

Again any help is apperciated! And I hope if anyone is above the 200K+ they have enjoyed there truck as much as mine.

Edit I just want to say sorry about my spelling and grammer I grew up in Hicktown texas sO I hope its not annoying for all of you! Please bare with me!
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!

Last edited by 08RecordRam; 12-11-2013 at 10:38 PM..
Reply With Quote
  #2  
Old 12-12-2013, 12:36 AM
Adambomber Adambomber is offline
Amateur
Garage is empty, add now
 
Join Date: Nov 2013
Posts: 32
Default

Idk if the 08 is different than an 03, but does your have the coolant resevoir with the pressurized cap? Is so, take of the cap and start your truck. If there is not a stream spraying into the coolant resevoir, then your waterpump is bad. Does it make a noise that sounds like its coming from a pulley if you open the hood?
Reply With Quote
  #3  
Old 12-12-2013, 10:16 AM
chuck_hammer's Avatar
chuck_hammer chuck_hammer is offline
Professional
Garage is empty, add now
 
Join Date: Aug 2013
Vehicle: 04 Dodge Ram 1500
Location: Ohio
Posts: 106
Default

I have seen the impeller on the water pump break off. and not move the water...but on the outside of the pump look fine.

remove the water pump... and check that the NEW thermostat is not stuck closed.

and I hope my V6 runs that long.
Reply With Quote
  #4  
Old 12-12-2013, 12:57 PM
08RecordRam 08RecordRam is offline
Amateur
Garage is empty, add now
 
Join Date: Dec 2010
Vehicle: 08 ram 1500
Location: Greenville/Celeste Texas
Posts: 28
Default

i tried the suggestion u gave me and the waterpump seems to be working...
Guess the combustion test in teh rad is the only thing left to do thenm most likely ill be dropping a good amount of breaed on the parts.
I figure ill go ahead and change the chain and sprockets for the timing while iam in there YAY
Reply With Quote
  #5  
Old 12-12-2013, 12:58 PM
08RecordRam 08RecordRam is offline
Amateur
Garage is empty, add now
 
Join Date: Dec 2010
Vehicle: 08 ram 1500
Location: Greenville/Celeste Texas
Posts: 28
Default

Quote:
Originally Posted by chuck_hammer View Post
I have seen the impeller on the water pump break off. and not move the water...but on the outside of the pump look fine.

remove the water pump... and check that the NEW thermostat is not stuck closed.

and I hope my V6 runs that long.
I think i will go ahead and break out the waterpump and get a new one, since the one I installed still is under warranty.
I think that will do just to be safe before i tear up the engine.

Thanks guys for the replys so far anything anyone suggest I will take to heart!
Reply With Quote
  #6  
Old 12-12-2013, 02:41 PM
Prismatic Prismatic is offline
Veteran
2002 Dodge Ram 1500
 
Join Date: Dec 2012
Posts: 267
Default

You let it go 19k miles without an oil change? The 3.7 is basically a 4.7 with two cylinders shaved off. These engines already have a sludge problem if you don't maintain the oil. You probably either clogged some oil passages, the screen, or both. Run an engine flush through... maybe a few times. Then put some seafoam in the oil and run it for a few hundred miles, then change with full synthetic and a quality filter.
__________________
I think i'll call it "Dodge Bodge"
The bodge
Reply With Quote
  #7  
Old 12-12-2013, 04:09 PM
08RecordRam 08RecordRam is offline
Amateur
Garage is empty, add now
 
Join Date: Dec 2010
Vehicle: 08 ram 1500
Location: Greenville/Celeste Texas
Posts: 28
Default

Sadly i did let it go that long, partly bc of ignorence. I was thinking I changed the oil but i guess I didnt.
How would i go about flushing the engine?
Reply With Quote
  #8  
Old 12-12-2013, 06:53 PM
Adambomber Adambomber is offline
Amateur
Garage is empty, add now
 
Join Date: Nov 2013
Posts: 32
Default

Yeah, like chuck hammer said, the water pump impeller can break and there is no outside sign. This happened on my 2003 dodge ram. I advise to take off the waterpump and check the impeller, it could have cracked around the center bolt and under a heavy load spin on the shaft and not turn the water. This was the case on mine but I didn't catch it until it completely stopped working. Also I agree that in the 3.7 and 4.7 you HAve to change the oil every 2000 miles
Reply With Quote
  #9  
Old 12-12-2013, 07:09 PM
08RecordRam 08RecordRam is offline
Amateur
Garage is empty, add now
 
Join Date: Dec 2010
Vehicle: 08 ram 1500
Location: Greenville/Celeste Texas
Posts: 28
Default

I appreciate everyones replys and advice I will be tackeling this tommorrow or saturday. Ive been cutting trees at my house and the neighbors after the bad storms and cleaning up.

One question I do have is IF i am leaking coolent IF it is going threw the exhuast the only cause for that would be the heads right?

Iam really hoping for the waterpump even at 280k miles i really dont want to have to tear up the motor and basicaly rebuild it. I could go to get a new truck but my uncle and grandmal are really giving me a hard time about buying one since i just bought 43 acres.
Reply With Quote
  #10  
Old 12-13-2013, 02:45 AM
KasperR34's Avatar
KasperR34 KasperR34 is offline
Captain
2005 Dodge Ram 1500
 
Join Date: Oct 2011
Vehicle: 2005 Dodge Ram 1500 QC 4x4
Location: Wolcott, CT
Posts: 587
Seth Groody KasperR34
Default

sell it and buy a hemi
__________________

12" Lift on 37x12.5R17
Reply With Quote
Old 12-13-2013, 02:45 AM
Reply
 
 
 




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 12:44 PM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2