Go Back   DodgeForum.com > Dodge Vans & CUVs > Dodge Caravan
Sign in using an external account
Register Forgot Password?


Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!

Need Help Diagnosing Plymouth Grand Voyager 96 Problem: No Start

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 11-15-2011, 02:35 PM
Mutt01 Mutt01 is offline
Registered User
Garage is empty, add now
 
Join Date: Nov 2011
Posts: 3
Default Need Help Diagnosing Plymouth Grand Voyager 96 Problem: No Start

I have a plymouth grand voyager 1996 3.3 liter engine.

It was running fine died on the freeway doing 60mph. There is gas in the oil and its firing but its not running. It will not start. I have checked the battery, the fuses, the starter, the relays, it is getting fuel but is not starting. Any ideas on where to start?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 11-15-2011, 03:58 PM
Cougar41 Cougar41 is offline
Record Breaker
Garage is empty, add now
 
Join Date: Feb 2011
Location: SoCal
Posts: 1,637
Default

Getting spark?
__________________
We took the time to answer your post. Please give us some time and post the fix. You'll help hundreds!
Reply With Quote
  #3  
Old 11-15-2011, 04:40 PM
Tizzy1's Avatar
Tizzy1 Tizzy1 is offline
Champion
Garage is empty, add now
 
Join Date: Jan 2010
Posts: 2,866
Default

did you actually check fuel pressure? Did the check engine lamp come on before it died, any codes?
Reply With Quote
  #4  
Old 11-15-2011, 05:07 PM
Mutt01 Mutt01 is offline
Registered User
Garage is empty, add now
 
Join Date: Nov 2011
Posts: 3
Default

I don't have the tool to check the fuel pressure, but I pulled the line it is getting fuel. No the check engine light did not come on first. I have an OBD2 Reader and no codes from it. Checked fusible links and they are fine. Yes it has spark. Trying to start but won't turn over.
Reply With Quote
  #5  
Old 11-16-2011, 11:19 AM
Tizzy1's Avatar
Tizzy1 Tizzy1 is offline
Champion
Garage is empty, add now
 
Join Date: Jan 2010
Posts: 2,866
Default

I have seen fuel pumps crap out where they kinda pump and you'll get 15 -20 psi of fuel pressure so when you pull the line it looks good but not enough to start. It will sound alot like you discribed, kinda fire but won't start.
Reply With Quote
  #6  
Old 11-23-2011, 10:22 PM
Mutt01 Mutt01 is offline
Registered User
Garage is empty, add now
 
Join Date: Nov 2011
Posts: 3
Default

it is the fuel pump gets enough electric so no codes just enough fuel not to give a fault but not enough fuel to run thankx guys have a nice thankx giving
Reply With Quote
  #7  
Old 11-23-2011, 11:42 PM
master tech's Avatar
master tech master tech is offline
Transmission God
Garage is empty, add now
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,273
Leonard Pierce
Default

Have you tried using starting fluid in the throttle body? And does it start and run?
__________________
Dodge Master Tech.
Reply With Quote
Old 11-23-2011, 11:42 PM
Reply
 
 
 




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 05:36 AM.

Internet Brands, Inc.


Contact Details & Emails

Search Engine Friendly URLs by vBSEO 3.5.2