89, base 2.5l issues - DodgeForum.com

1st Gen Dakota Tech 1987 - 1996 Dodge Dakota Tech - The ultimate forum for technical help on the 1st Gen Dakota.
Sponsored By:
Sponsored By:

89, base 2.5l issues

  #1  
Old 01-10-2019, 04:40 AM
Mitch Geiger
Mitch Geiger is offline
Registered User
Thread Starter
Join Date: Jan 2019
Posts: 1
Default 89, base 2.5l issues

Hi all, I bought a 89 Dakota base model with 2.5l engine a couple weeks ago and I have encountered a few problems. It started with the parking brake not engaging, the the anti-lock light turned on in my gauge cluster, the most recent problem I encountered was tonight when I left my work (oreilly's) I came to a stop with my foot pushing in the clutch pedal all the way, the engine stalled twice when I quit rolling completely. Not sure what is going on, the odometer stopped working a couple days ago at 139,977 miles. I'm not sure what I should do to fix the problem, I am also planning on doing a 5.9 magnum swap later this year with the buddies in the group I am in. If anyone can please chime in that would be amazing, I love this little truck to death
Mitch
 
  #2  
Old 01-10-2019, 08:05 AM
RalphP
RalphP is offline
Champion
Join Date: Jan 2013
Location: Northwest Louisiana
Posts: 2,531
Default

You're not sure what to do to fix WHICH of the four problems you listed?

Parking Brake not engaging - that can be a whole long list of possible causes. Time to drag out the factory service manual (hint: Is your truck a Chilton Dakota or a Haynes Dakota? Then no, those aren't FACTORY service manuals ... the FSM was printed by Bishko for Mother Mopar, and can be found used on Ebay, sometimes new at Bishko and other sources) but my first WAG is to check the rear brakes for proper adjustment and state of life, and then check the cables for possible stretch or breakage.

Anti-Lock light turning on? Not sure your truck HAS anti-lock on it - sounds like the faceplate was swapped with a newer one, or the fuel gauge. But again, check the overall state of the brakes FIRST. Especially since the anti lock on a base unit would be rear only anti-lock; could be it's reporting on the first problem!

Motor stalling when clutch pedal is in and you're in gear? Sounds like time to do the clutch; it's dragging. Again, check the fluid in the CLUTCH reservoir, make sure it's not too low.

Odometer broken? You can buy the gears yourself, or just swap out the speedometer with a junkyard pull.

RwP
 

Thread Tools
Search this Thread
Quick Reply: 89, base 2.5l issues


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: