91 W150 Running out of Steam - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 1st Gen Ram Tech
Reload this Page >

91 W150 Running out of Steam

1st Gen Ram Tech '93 & older Rams: This section is for TECHNICAL discussions only, that involve 1993 Rams and older. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

91 W150 Running out of Steam

Reply

 
 
 
  #1  
Old 09-18-2018, 01:22 PM
SG19
SG19 is offline
Registered User
Thread Starter
Join Date: Sep 2017
Location: Iowa
Posts: 10
Default 91 W150 Running out of Steam

Hello everyone , I have a 91 W150 318 that had sat mostly for the last 5 years. I had been starting it occasionally and this spring decided I needed it for some projects.



It wouldn't start this spring , 1st time ever. I procrastinated till about a month ago. Put a fuel pump & new battery in and she fired right up , also started spewing gas under the bed as a fuel line had rotted through.



Got a new set of fuel lines from Rock Auto along with a fuel filter , fixed . . . .short test drive and the upper radiator hose blew out ! Put new upper & lower hoses , water inlet , and thermostat with all fresh coolant.



She runs fine up to about 40mph , then it's a major struggle to get more speed out of her , 45 took awhile.



It seems to shift fine , snaps into gears pretty good for an automatic ,it hit 3rd by 25ish mph. Seems to me this was the issue it had when I stopped driving it vary much.

Going by the local muffler shop , they will pressure test the exhaust for free.



Any other ideas ?
 
Reply With Quote
  #2  
Old 09-18-2018, 02:31 PM
crazzywolfie's Avatar
crazzywolfie
crazzywolfie is offline
Grand Champion
Join Date: Jun 2009
Location: orangeville ontario
Posts: 7,187
Default

does it make you go into 3rd at 25mph no matter what? it might do that under very light throttle but shouldn't under heavy or full throttle. under full throttle it should probably hold 1st gear till about 30-40mph depending on the gears in the rear end and how the kick down linkage is adjusted. it sounds like you may need to adjust the kick down linkage a bit tho
 
Reply With Quote
  #3  
Old 09-18-2018, 06:26 PM
SG19
SG19 is offline
Registered User
Thread Starter
Join Date: Sep 2017
Location: Iowa
Posts: 10
Default

I'll have to take it out for a spin and pay closer attention , it's not the best accelerating lumber wagon on good days anyway.
 
Reply With Quote
  #4  
Old 09-18-2018, 06:48 PM
crazzywolfie's Avatar
crazzywolfie
crazzywolfie is offline
Grand Champion
Join Date: Jun 2009
Location: orangeville ontario
Posts: 7,187
Default

they are not super fast but usually once they hit about 2000rpm they start moving pretty good. i know i do it all the time in my 89 since there is no second gear and you need run it up to 45mph in 1st to kind of compensate and then let it shift into 3rd but i had to adjust the kick down linkage in order to get the transmission to do that fairly smoothly.
 
Reply With Quote
  #5  
Old 09-18-2018, 08:49 PM
SG19
SG19 is offline
Registered User
Thread Starter
Join Date: Sep 2017
Location: Iowa
Posts: 10
Default

So it's more like 35 mph it hits 3rd , wish it had a tack , it rev's pretty good in P / N , it just struggles to past 40 mph. I'll get the exhaust tested though I've never encountered a plugged cat before , at least I can eliminate it. The rubber isn't aging vary well so I'm thinking about replacing some vacuum lines , it's a cheap fix , also checking torque on the intake manifold bolts.

I could pull the throttle body and give it a good cleaning , I've had this truck since 2002 and none of that stuffs been done since I've had it , unless you think I'm on a witch hunt.
 
Reply With Quote
  #6  
Old 09-18-2018, 09:28 PM
HeyYou's Avatar
HeyYou
HeyYou is online now
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 53,190
Default

Everyone loves a good witch hunt every now and again.

Sounds like your cat is clogging up.
 
Reply With Quote
  #7  
Old 09-18-2018, 11:20 PM
crazzywolfie's Avatar
crazzywolfie
crazzywolfie is offline
Grand Champion
Join Date: Jun 2009
Location: orangeville ontario
Posts: 7,187
Default

have you tried manually putting it in 1st or second gear and then 2nd gear and seeing how it does and if you can get past the 35mph in second. if you can shift from first to 2nd at 35mph that will help keep the engine in the working power area when it hits 2nd so hopefully it will just keep building speed
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Quick Reply: 91 W150 Running out of Steam


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: