backfire loss of power - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Reload this Page > backfire loss of power
Notices
2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

backfire loss of power

Reply

 
 
  #1  
Old 12-13-2013, 10:06 AM
michaelgeller294's Avatar
michaelgeller294
michaelgeller294 is offline
Registered User
Thread Starter
Join Date: Dec 2013
Posts: 5
Default backfire loss of power

i have the 5.2 i have checked the o2 sensors nothing wrong with them checked the map sensor the plenum seems to be fine changed the plugs and wires the cat was gutted after this happened it wasnt the issue im running out of ideas as to what it can be it throws about 20 codes when i plug it in but there never the same codes
 
Reply With Quote
  #2  
Old 12-13-2013, 11:10 AM
TheBigRedTruck
TheBigRedTruck is offline
Veteran
Join Date: Jan 2013
Location: New York
Posts: 261
Default

need info on your truck...year model etc..
 
Reply With Quote
  #3  
Old 12-13-2013, 11:17 AM
michaelgeller294's Avatar
michaelgeller294
michaelgeller294 is offline
Registered User
Thread Starter
Join Date: Dec 2013
Posts: 5
Default

its a 99 dodge ram 1500
 
Reply With Quote
  #4  
Old 12-13-2013, 11:39 AM
Ham Bone's Avatar
Ham Bone
Ham Bone is offline
Champion
Join Date: Aug 2011
Location: Blacksburg, VA
Posts: 4,068
Default

Sounds like your PCM is going bonkers. Did you disconnect battery when changing stuff? Even if you did, disconnect battery then cut your headlights on to drain the system. Then reconnect and see what happens.

If it's still going crazy it's time to start to tracing grounds
 
Reply With Quote
  #5  
Old 12-13-2013, 11:41 AM
michaelgeller294's Avatar
michaelgeller294
michaelgeller294 is offline
Registered User
Thread Starter
Join Date: Dec 2013
Posts: 5
Default

the battery was out of it for a month and its still acting up
 
Reply With Quote
  #6  
Old 12-13-2013, 12:17 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 45,375
Default

Time for a compression/leakdown test.
 
Reply With Quote
  #7  
Old 12-13-2013, 09:01 PM
ReadRam
ReadRam is offline
All Star
Join Date: Jul 2010
Location: fargo, n.d
Posts: 782
Default

I'm lost. Besides throwing codes, what is acting up?
 
Reply With Quote
  #8  
Old 12-14-2013, 05:09 AM
michaelgeller294's Avatar
michaelgeller294
michaelgeller294 is offline
Registered User
Thread Starter
Join Date: Dec 2013
Posts: 5
Default

it backfires when at idle and has a major loss of power it takes a full mile to hit 60
 
Reply With Quote
  #9  
Old 12-14-2013, 10:55 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 45,375
Default

Backfiring out the exhaust, or intake?
 
Reply With Quote
  #10  
Old 12-14-2013, 10:58 AM
dhvaughan's Avatar
dhvaughan
dhvaughan is offline
Hall Of Fame
Join Date: Jul 2006
Location: Gainesville, Ga.
Posts: 12,203
Default

do a compression test.
 
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Soco3087
3rd Gen Dakota
8
11-12-2015 11:33 AM
squigg
2nd Gen Dakota
6
08-06-2015 03:37 PM
Marty_g
1st Gen Dakota
3
08-05-2015 10:24 PM
toolbox07
2nd Gen Dakota
2
07-28-2015 04:44 PM
Hollywood 24
1st Gen Ram Tech
1
07-25-2015 09:34 AM

Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 01:04 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: