Brake and Cooling problems - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 2nd Gen Ram Tech
Reload this Page >

Brake and Cooling problems

Notices
2nd Gen Ram Tech 1994-2001 Rams: This section is for TECHNICAL discussions only, that involve the 1994 through 2001 Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Brake and Cooling problems

Reply

 
 
 
  #1  
Old 05-14-2018, 12:15 AM
MoparFanatic21
MoparFanatic21 is offline
Captain
Thread Starter
Join Date: Nov 2014
Posts: 746
Default Brake and Cooling problems

Two odd problems with my 01 Ram 2500 5.9L V8
1st problem: Over cooling in the winter and running a little hot in the summer. I had to tow my dad's 06 Ram Big Horn because his passenger wheel bearing went and the wheel was sorta locked got way past the half mark, on the gauge. In the winter it has very little heat. I do have a little coolant leak where that metal hose meets the water pump but I top off the fluid and both instance the fluid level were good.
2nd problem: since I got my ABS lights to go out now the pedal is acting weird one minute it will be "soft" literally next push it's hard as a rock and wonderfully touchy brakes like I like it too be. But if you hold them you will hit hear a loud click type sound and pedal will slowly go down, this happens when the pedal is rock hard. This truck is suppose to have hydraboost as it was a diesel but has the vacuum brake booster. Any ideas??
 

Last edited by MoparFanatic21; 05-14-2018 at 07:55 AM.
Reply With Quote
  #2  
Old 05-14-2018, 07:46 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 49,952
Default

Wow man, autocorrect on your phone is slaughtering your posts.
 
Reply With Quote
  #3  
Old 05-14-2018, 07:55 AM
MoparFanatic21
MoparFanatic21 is offline
Captain
Thread Starter
Join Date: Nov 2014
Posts: 746
Default

Originally Posted by HeyYou View Post
Wow man, autocorrect on your phone is slaughtering your posts.
Fixed yeah it sucks not having a computer. My phone tries to predict the sentence for me.
 
Reply With Quote
  #4  
Old 05-14-2018, 08:01 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 49,952
Default

Probably have an air pocket in the heater core yet. They are notoriously difficult to burp out.

If you have RWAL, I would just disable it, it sucked when it was new. It is less than useless. Not sure about hydraboost, I didn't think even the diesels used it.......
 
Reply With Quote
  #5  
Old 05-14-2018, 09:27 AM
2bit's Avatar
2bit
2bit is offline
Captain
Join Date: Jul 2014
Location: Wisconsin
Posts: 616
Default

You might need a new thermostat and water pump. Look at the 95 Oxidizer Special thread in the non-tech section. I installed E-fans from an LS-1 camaro. They fit really well. I have more pictures, I was always going to do a how-to thread.
 
Reply With Quote
  #6  
Old 05-14-2018, 10:20 AM
MoparFanatic21
MoparFanatic21 is offline
Captain
Thread Starter
Join Date: Nov 2014
Posts: 746
Default

Originally Posted by 2bit View Post
You might need a new thermostat and water pump. Look at the 95 Oxidizer Special thread in the non-tech section. I installed E-fans from an LS-1 camaro. They fit really well. I have more pictures, I was always going to do a how-to thread.
I am going to get a thermostat what's the lowest I can go with the CEL coming on? Water pump is brand new Mopar one. I want to do E-Fans but had bad luck with them towing. I am planning to install one in front of everything as a helper fan with AC like the 1st Gen durangos had.
 
Reply With Quote
  #7  
Old 05-14-2018, 10:23 AM
2bit's Avatar
2bit
2bit is offline
Captain
Join Date: Jul 2014
Location: Wisconsin
Posts: 616
Default

I thought some had problems with a 180. Hey You probably knows for sure.
 
Reply With Quote
  #8  
Old 05-14-2018, 01:06 PM
MoparFanatic21
MoparFanatic21 is offline
Captain
Thread Starter
Join Date: Nov 2014
Posts: 746
Default

Originally Posted by 2bit View Post
I thought some had problems with a 180. Hey You probably knows for sure.
Yeah he'll eventually see and chime in 😂
 
Reply With Quote
  #9  
Old 05-14-2018, 04:31 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 49,952
Default

With the older electronics in your truck, it isn't quite as picky. Still, I wouldn't go any lower than 180, otherwise, gas mileage will suffer. (even more....) The 98 and newer electronics are a lot more picky.
 
Reply With Quote
  #10  
Old 05-14-2018, 04:40 PM
MoparFanatic21
MoparFanatic21 is offline
Captain
Thread Starter
Join Date: Nov 2014
Posts: 746
Default

Originally Posted by HeyYou View Post
With the older electronics in your truck, it isn't quite as picky. Still, I wouldn't go any lower than 180, otherwise, gas mileage will suffer. (even more....) The 98 and newer electronics are a lot more picky.
well am in the process of making it into a 01 electronics again so will 180 set the CEL when I get that dash and everything in?
 
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Brake and Cooling problems


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: