Loss of acceleration and power - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Dakota > 3rd Gen Dakota
Reload this Page > Loss of acceleration and power
3rd Gen Dakota 2005+ Dakota's

Loss of acceleration and power

Reply

 
 
  #1  
Old 08-09-2017, 11:57 AM
Dual
Dual is offline
Registered User
Thread Starter
Join Date: Aug 2017
Posts: 5
Default Loss of acceleration and power

2005 Dakota Quad Cab 3.7. My truck loses power going uphill. I push the gas pedal all the way down and can barely get to 40 mph on hills. I have had the exhaust checked (cats) as well as rebuilt the top end of the engine. Compression check done by more then one shop. MAP sensor replaced, as well as EVAP. Also having problems with it going into park but I know there is a recall or TSB for that. I have put so much money into fixing this problem that I am at a loss here. I don't know if I need a computer flash to fix the problem or if there is something else. If anyone here knows whats going on or had same problem I could use help before I take it to the shop again. Also there is no fault code showing in computer.
 

Last edited by Dual; 08-09-2017 at 12:00 PM. Reason: Added more information
Reply With Quote
  #2  
Old 08-09-2017, 12:18 PM
jkeaton's Avatar
jkeaton
jkeaton is offline
Site Moderator
Join Date: Apr 2010
Location: Winston Salem, NC
Posts: 20,218
Default

Maybe look at the transmission instead if the engine is checking out good.
 
Reply With Quote
  #3  
Old 08-10-2017, 07:34 AM
WvChamp
WvChamp is offline
Amateur
Join Date: Apr 2007
Location:
Posts: 34
Default

Tested fuel pump pressure and Volume?
Codes ?
 
Reply With Quote
  #4  
Old 08-10-2017, 06:15 PM
Dual
Dual is offline
Registered User
Thread Starter
Join Date: Aug 2017
Posts: 5
Default

Yes I had pressure test on fuel done and it is good. I had hoped it was the filter but no such luck. I read on another post that it could be the converter and converter clutch. So I am going to take it in sometime next week and have a check done on it. Just real tired of throwing money at it and no shop has been able to find/fix it yet. Only good thing is when this gets fixed I will have almost a brand new truck. Please continue on with comments or questions, so I can get this fixed. Oh and no codes at all.
 
Reply With Quote
  #5  
Old 08-10-2017, 08:20 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 44,004
Default

Is it ONLY going uphill? Does it run ok on the flat?
 
Reply With Quote
  #6  
Old 08-11-2017, 03:31 PM
Jaded's Avatar
Jaded
Jaded is offline
All Star
Join Date: Dec 2006
Location: Mobile, AL
Posts: 793
Default

is it downshifting? have you tried hitting tow/haul?
 
Reply With Quote
  #7  
Old 08-11-2017, 05:35 PM
superdak05's Avatar
superdak05
superdak05 is offline
Champion
Join Date: Mar 2006
Location: ct.
Posts: 4,610
Default

disconnect the battery over night to exhaust all power to computer. reconnect and start and stop truck three times, on third time leave truck running for about 5 minutes, then get in it and drive it like you stole it, should clear what ever issue your having. if not, converter may be locking up to soon.
 
Reply With Quote
  #8  
Old 08-11-2017, 07:53 PM
Dual
Dual is offline
Registered User
Thread Starter
Join Date: Aug 2017
Posts: 5
Default

Originally Posted by HeyYou View Post
Is it ONLY going uphill? Does it run ok on the flat?
On flat ground it has get up and go but not like it should. On hills it has no power. Sometimes it will downshift but it revs up really high for a short time then upshifts to next highest gear.
 
Reply With Quote
  #9  
Old 08-11-2017, 07:53 PM
Dual
Dual is offline
Registered User
Thread Starter
Join Date: Aug 2017
Posts: 5
Default

Originally Posted by Jaded View Post
is it downshifting? have you tried hitting tow/haul?
Yes I have tried the tow/haul and no change
 
Reply With Quote
  #10  
Old 08-11-2017, 07:55 PM
Dual
Dual is offline
Registered User
Thread Starter
Join Date: Aug 2017
Posts: 5
Default

Originally Posted by superdak05 View Post
disconnect the battery over night to exhaust all power to computer. reconnect and start and stop truck three times, on third time leave truck running for about 5 minutes, then get in it and drive it like you stole it, should clear what ever issue your having. if not, converter may be locking up to soon.

I have a feeling its the converter and the converter clutch.... I will try this out and see what happens.
 
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors

All times are GMT -4. The time now is 09:41 PM.