Go Back  DodgeForum.com > Dodge Trucks > Dodge Dakota > 3rd Gen Dakota
Reload this Page >

"No Fuse" warning. '08 Dakota. IOD fuse?

3rd Gen Dakota 2005 - 2011 Dodge Dakota Tech - The ultimate forum for technical help on the 3rd Gen Dakota.

"No Fuse" warning. '08 Dakota. IOD fuse?

  #1  
Old 07-10-2019, 07:20 PM
handwedge
handwedge is offline
Registered User
Thread Starter
Join Date: Aug 2018
Location: Vernon, BC
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default "No Fuse" warning. '08 Dakota. IOD fuse?

Hi there --
I left my 08 Dakota SLT in storage for two months and the battery went dead. My friend trickle charged it before I got home but it wouldn't start for him. I trickle charged it again when I got home, but when I tried to start it, all I heard was the "CLICK CLICK" of the truck trying to turn over, then it stopped. It showed the message "NO FUSE" on the dash.
All electrical things work except the Radio. After consulting the manual, it looks like the Ignition Off Draw (IOD) and radio are on the same 20A Yellow mini fuse. I checked them all and they looked ok. (not exactly sure which one is IOD/Radio -- can't seem to find a helpful diagram of the power distro center for this truck).

The only other thing I can find that doesn't work is the rear-right power window (and I'm not sure if it worked before -- I've only had the truck for a year). Could that be a short that's screwing everything up?
I've attached a photo of my power distro center for reference.

Also, if anyone could tell me why that random yellow wire is plugged into one of the empty fuse slots, that would be great. It came out when I took the cover off -- and I'm not sure if I put it back in the right hole.

Any ideas would be greatly appreciated.

Thanks


 
  #2  
Old 07-11-2019, 03:09 PM
dakotaff's Avatar
dakotaff
dakotaff is offline
Champion
Join Date: Aug 2009
Location: Jersey
Posts: 3,679
Likes: 0
Received 0 Likes on 0 Posts
Default

#6 should be the IOD/Radio fuse.

I'd start with getting a new battery first.
 
  #3  
Old 07-11-2019, 04:24 PM
handwedge
handwedge is offline
Registered User
Thread Starter
Join Date: Aug 2018
Location: Vernon, BC
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Good call -- it was a bad cell in the battery (not sure why it was affecting a perfectly good fuse or if the battery just made everything wonky.
Relieved it wasn't anything more serious.
Thanks!
 
  #4  
Old 07-11-2019, 05:38 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 57,634
Likes: 0
Received 34 Likes on 34 Posts
Default

Low battery voltage prompts all sorts of strange behavior in these trucks.
 
The following users liked this post:
RacerHog (07-11-2019)

Thread Tools
Search this Thread
Quick Reply: "No Fuse" warning. '08 Dakota. IOD fuse?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: