Cruise Control shuts off after 30 seconds - DodgeForum.com

Go Back  DodgeForum.com > Dodge Vans & CUVs > Dodge Caravan
Reload this Page > Cruise Control shuts off after 30 seconds
Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!

Cruise Control shuts off after 30 seconds

Reply

 
 
  #1  
Old 09-30-2011, 06:33 PM
J Beck
J Beck is offline
Registered User
Thread Starter
Join Date: Sep 2011
Posts: 6
Default Cruise Control shuts off after 30 seconds

I have a 2001 caravan. When I'm driving along and engage the cruise control, the light comes on and the cruise works for about 30 seconds. After that, the light goes off and the cruise will not work. I cannot re-engage the cruise control again unless I turn the key off and restart the engine.

Please help in finding the cause and fix.
 
Reply With Quote
  #2  
Old 09-30-2011, 11:39 PM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,847
Default

Do you know if the check engine light came on? Also has there been any transmission repairs or LDP pump replaced?
 
Reply With Quote
  #3  
Old 10-01-2011, 07:04 PM
J Beck
J Beck is offline
Registered User
Thread Starter
Join Date: Sep 2011
Posts: 6
Default

Thanks for responding.

The engine check light does not come on. There are no error codes when we check the main computer.

I just changed the transmission computer and had it flashed. The problem was that the car was in limp mode and the computer was all messed up. I did not have the cruise problem prior to the change in the computer. The speedometer is working.

Any recommedations would be greatly appreciated.
 
Reply With Quote
  #4  
Old 10-01-2011, 11:59 PM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,847
Default

Check the wires going to the top of the rear transmission mount. If the wires are grounding that will cause the same type of problem. That doesn't mean that is what is wrong with your speed control.
 
Reply With Quote
  #5  
Old 10-02-2011, 10:23 AM
J Beck
J Beck is offline
Registered User
Thread Starter
Join Date: Sep 2011
Posts: 6
Default

I'll try it in the next few days and let you know.

Thanks
 
Reply With Quote
  #6  
Old 10-03-2011, 11:55 AM
J Beck
J Beck is offline
Registered User
Thread Starter
Join Date: Sep 2011
Posts: 6
Default

I checked the wires and they looked fine. There appeared to be no exposed wiring that would cause grounding.

Any other suggestions?

Thanks
 
Reply With Quote
  #7  
Old 10-03-2011, 12:22 PM
J Beck
J Beck is offline
Registered User
Thread Starter
Join Date: Sep 2011
Posts: 6
Default

Does the transmission computer have any effect on the cruise? Could the new computer be defective or the flashing was done incorrectly? I never had a problems with the cruise until I replaced the transmission computer. The speedometer is working so that's not the problem.

Thanks
 
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jayz55
2nd Gen RAM general discussion/NON-tech
18
08-03-2015 12:04 PM
jimbaughan
Dodge Ram Van
0
07-24-2015 02:51 PM
Davids Charger
Dodge Charger
2
07-22-2015 12:55 AM
JoshSlash87
3rd Gen Ram Tech
1
07-14-2015 07:51 AM
OptimalRhyme
2nd Gen Ram Tech
8
07-06-2015 10:06 AM


Thread Tools
Search this Thread
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Get repairs made easy
Print and online manuals

Find manuals

Featured Sponsors

All times are GMT -4. The time now is 02:15 PM.