Go Back   DodgeForum.com > Dodge Trucks > Dodge Ram > 4th Gen Ram Tech
Sign in using an external account
Register Forgot Password?


4th Gen Ram Tech 2009+ and up Rams: This section is for TECHNICAL discussions only, that involve the 2009 and up Rams. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

2011 1500 5.7 Fuel Pump Issue

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-21-2011, 10:38 PM
kevsram1500 kevsram1500 is offline
Registered User
 
Join Date: May 2011
Vehicle: Ram 1500 5.7 HEMI
Location: Littleton
Posts: 11
Default 2011 1500 5.7 Fuel Pump Issue

Hello, I have less than 7800 miles on my new Ram 1500 and just yesterday the truck died on the road. Lost power to everything, brakes, steering and engine. Delarship thinks it is the fuel pump. Anyone else having issues like this?
Thanks
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 05-21-2011, 10:53 PM
kennisonxgs kennisonxgs is offline
Registered User
 
Join Date: Mar 2011
Posts: 19
Default

Any code?
Reply With Quote
  #3  
Old 05-22-2011, 10:27 AM
kevsram1500 kevsram1500 is offline
Registered User
 
Join Date: May 2011
Vehicle: Ram 1500 5.7 HEMI
Location: Littleton
Posts: 11
Default

Dealership has not mentioned any codes. I will check with them when they open on Monday.
Reply With Quote
  #4  
Old 05-22-2011, 11:33 AM
HammerZ71's Avatar
HammerZ71 HammerZ71 is offline
Administrator
Dodge Forum Administrator
 
Join Date: Jul 2007
Vehicle: 2014 2500 CTD 4x4
Location: South Georgia/East Florida
Posts: 23,907
Default

you're the second or third one now mentioned a dead fuel pump in a 4th Gen, can't remember if the others were 2011s or not. I mentioned in the first guy's post that it was prolly a fluke, anybody can get a bad one, but I now know of two guys locally that had their fuel pumps go out in 2011 Rams, one a 1500, the other a 2500 Hemi.

I'm thinkin' good old Dodge changed vendors for a cheaper one again... Hope not, but it's lookin' that way. I'll have to do some digging and see if/when part number may have changed...
Reply With Quote
  #5  
Old 05-22-2011, 12:45 PM
CarGuyOhio's Avatar
CarGuyOhio CarGuyOhio is offline
Admin formally known as 94rt10ohio
 
Join Date: Apr 2005
Vehicle: 12 Challenger SRT Yellow Jacket, 14 Wranger Sahara 2 Door
Location: Curtice, OH
Posts: 9,021
Default

Quote:
Originally Posted by kevsram1500 View Post
Lost power to everything, brakes, steering and engine. Thanks
To everything or just those you listed? Would it turn over? Did you loose power windows, locks, radio??
__________________
14 Jeep Wrangler Sahara 2 Door
12 Challenger SRT 392 Yellow Jacket Kenne Bell Supercharged among others.
Reply With Quote
  #6  
Old 05-22-2011, 12:48 PM
kevsram1500 kevsram1500 is offline
Registered User
 
Join Date: May 2011
Vehicle: Ram 1500 5.7 HEMI
Location: Littleton
Posts: 11
Default

Thanks for that information, seems like a low number however, factor in two in the same town/city?
I am told the part is on national back order, no time point given for delivery. Should i just buy one at the Auto parts store and have them install under the warranty?
Just wondering out loud.
Take care
Reply With Quote
  #7  
Old 05-22-2011, 01:07 PM
kevsram1500 kevsram1500 is offline
Registered User
 
Join Date: May 2011
Vehicle: Ram 1500 5.7 HEMI
Location: Littleton
Posts: 11
Default

Electrical still worked
Reply With Quote
  #8  
Old 05-22-2011, 03:37 PM
CarGuyOhio's Avatar
CarGuyOhio CarGuyOhio is offline
Admin formally known as 94rt10ohio
 
Join Date: Apr 2005
Vehicle: 12 Challenger SRT Yellow Jacket, 14 Wranger Sahara 2 Door
Location: Curtice, OH
Posts: 9,021
Default

I bet the pump on BO has to do with Japan....

I am not 100% sure they would do that, you would, at a minimum, loose any future warrany on a fuel pump related issue.
__________________
14 Jeep Wrangler Sahara 2 Door
12 Challenger SRT 392 Yellow Jacket Kenne Bell Supercharged among others.
Reply With Quote
  #9  
Old 08-22-2011, 03:07 PM
stevesy stevesy is offline
Registered User
 
Join Date: Aug 2011
Posts: 1
Default

Quote:
Originally Posted by kevsram1500 View Post
Thanks for that information, seems like a low number however, factor in two in the same town/city?
I am told the part is on national back order, no time point given for delivery. Should i just buy one at the Auto parts store and have them install under the warranty?
Just wondering out loud.
Take care
Same thing happened to me this Saturday. Part is still on back order. All I know is if they don't locate one today I'm going to be furious. I had a working vehicle that I traded in to get this 2011 in April. Only reason I did was because I was worried of possible breakdowns. Now I have a brand new truck that's broken down for who knows how long. That's just BS...maybe I'll get lucky and end this with a happy note later today when they call me to tell me they got one.
Reply With Quote
  #10  
Old 09-26-2011, 03:09 PM
Fishing Boyz Fishing Boyz is offline
Registered User
 
Join Date: Sep 2011
Posts: 1
Default

Well make it another. 11,186 miles on my 2011 1500 and I am sitting on the side of the road. Dealer says it is the fuel pump and there is only one in the country that they know of.

Electrial all was still in working order.

The only pre-curser to the whole story was about 3 weeks ago while I was driving and my gas gauge went from 1/3 to 0 and then cam back up. That was a little weird watching it slowing go down - never losing power - then come back up. Never saw the problem since then so I never thought about bring the vehicle in. How would y0ou explain that? and your vehicle is working now, sir? type of thing.

Hope it is only the fuel pump and the next one does not have any trouble.
Reply With Quote
  #11  
Old 09-27-2011, 11:21 AM
mike2810 mike2810 is offline
Captain
 
Join Date: Feb 2009
Vehicle: 2009 Ram 1500 Quad SLT 4x4
Location: AZ
Posts: 558
Default

May be isolated to the 2011's, I have not had a fuel pump issue on my 09 (21,000mi).

Hope Dodge gets you all on the road again soon.
__________________
2009 Ram Quad SLT 4x4 Hemi,
mopar nerf bars, mud flaps, sprayed in bed liner.
Reply With Quote
  #12  
Old 09-27-2011, 12:27 PM
JohnVI JohnVI is offline
Veteran
 
Join Date: Mar 2009
Posts: 269
Default

Quote:
Originally Posted by mike2810 View Post
May be isolated to the 2011's, I have not had a fuel pump issue on my 09 (21,000mi).

Hope Dodge gets you all on the road again soon.

I was just thinking the same thing. I wonder if DODGE changed parts from 09 to 11, as no posts for this issues on 09's can be found (With my lack of search skills)...

and if the part is on backorder, is that a sign this might be a future recall, or am I thinking too deeply..
__________________
2009 TRX4 RAM - Inferno Red Crystal Pearl, U-Connect, Hitch, Recon Scanning LED Tailgate Bar, Recon DRL in lower Air Damn, Volant Cold Air Intake, Mopar BedRug, Resonator Removed, Superchips Tuned, *new* Bakflip Roll-X cover, Kenwood DVD entertainment system with HDMI headrests, LED's for interior and license plate, Muilti-Color LED strip lighting in bed
Reply With Quote
  #13  
Old 05-12-2012, 08:10 PM
WSAOK WSAOK is offline
Registered User
 
Join Date: May 2012
Posts: 1
Default

Please forgive me for the thread revival. I did a Google search for "2011 Ram Fuel Pump Problems" and found this thread and site. I thought I would share my experiences.

I have a 2011 Ram company truck with the 5.7 Hemi. The truck died about a block from my office late July / early August last year. It was determined to be a bad fuel pump which was on national backorder (as I have also read here - I think I waited at least four weeks to get the truck back). The fuel gauge went from the actual reading to zero prior to me being stranded as well. I can go back and look at mileage, although I am guessing the truck was in the 6K to 8K range.

The truck left my stranded again today, some 170 miles from home, with around 26K miles on it. Roadside Assistance towed it to the nearest dealer who thinks it is the fuel pump. I told them this was twice.

In my mind, this is getting ridiculous, and I no longer trust the truck for long trips.

I see what transpires this week.
Reply With Quote
  #14  
Old 05-13-2012, 11:08 AM
kevsram1500 kevsram1500 is offline
Registered User
 
Join Date: May 2011
Vehicle: Ram 1500 5.7 HEMI
Location: Littleton
Posts: 11
Default

Sorry to hear you are going on your third pump. Major pain the ***. I still love my truck, knock on wood, it has had no issues since. Good luck
Reply With Quote
  #15  
Old 05-13-2012, 11:20 AM
huntergreen huntergreen is offline
Professional
 
Join Date: Jan 2011
Posts: 187
Default

13000 miles on my 11, no issue so far. i never let my truck get below 1/4 tank as the gas hoping that this keeps the pump from heating up and burning out. no clue if this really works on fuel pump longevity, but i have never had an in the tank fuel pump fail on me.
Reply With Quote
  #16  
Old 05-13-2012, 02:06 PM
ridiculous11 ridiculous11 is offline
Registered User
 
Join Date: May 2012
Vehicle: 2011 Ram 1500 Crew Cab 4x4
Location: Nebraska
Posts: 14
Default

They have few parts on national backorder, i need a wheel speed sensor and it was on back order. they couldnt give me a date on when to get one or anything. i called around and found that there was other dealerships that had em on there damn shelf. called Car City Dodge Chrysler and jeep back and told them i found one at another dealership. they then called em and i had the part 3 days later.
Reply With Quote
  #17  
Old 07-31-2012, 09:23 PM
mriboy mriboy is offline
Registered User
 
Join Date: May 2011
Vehicle: 2011 Challenger SRT8 / Ram Sport 1500
Location: Bullhead City , Az
Posts: 4
Default

Make it another 10,236 miles dead on side of the road 2011 5.7 1500. Sarted with erratic gas guage the replaced the sensor last week now died last night. Had it towed to dealership said they had to order a fuel pump. Had my kids with me so it was pretty bad waiting for a tow placed a order for a 2012 2500 today dont need this happening when we are 100 miles from nowhere out here in the desert when its 120.

Last edited by mriboy; 07-31-2012 at 09:31 PM..
Reply With Quote
  #18  
Old 08-02-2012, 08:20 AM
ice2ebay ice2ebay is offline
Registered User
 
Join Date: Aug 2012
Posts: 1
Default

Had my 2011 Dodge Ram 1500 Laramie die last week at 15k. Starrted with gas gauge reading incorrectly, had it towed to the shop and they confirmed it was fuel pump. Took a week to recieve truck back, 2 days later the gas gauge is dropping to empty and when i filled up it only took 16 gallons.....Starting to doubt reliability from this truck...Calling the dealership back today
Reply With Quote
  #19  
Old 08-04-2012, 08:54 AM
LU229 LU229 is offline
Banned
 
Join Date: Jun 2011
Posts: 1,770
Default

2010 hemi qc sport 4x4 with 46,000 miles on mine, havent had any fuel pump issue as of yet, now i`ve prolly jink`s myself by saying somethin about it. I`ve had tons of other "quality" issues with this truck since new, so as soon as its paid down enough, its going bye-bye. I would NEVER buy another one either... but thats my choice.
Reply With Quote
  #20  
Old 08-04-2012, 12:04 PM
Nate769 Nate769 is offline
All Star
 
Join Date: Jan 2010
Vehicle: 2012 3500 Cummins
Location: Alberta
Posts: 824
Default

Quote:
Originally Posted by huntergreen View Post
13000 miles on my 11, no issue so far. i never let my truck get below 1/4 tank as the gas hoping that this keeps the pump from heating up and burning out. no clue if this really works on fuel pump longevity, but i have never had an in the tank fuel pump fail on me.
Be curious to see if this actually works too, might be a time to call in the mythbusters!

Anyways I have 30k kms on mine, and I have run it all the way down to fumes, several times. But as someone who does the exact opposite of you, I can say there are no issues as of yet "knock knock."

I have not heard of anyone with this issues up until I looked at this thread. Wonder if just a bad run of pumps were sent out? Or can anyone even claim that they swapped manufactures for 2011? Kind of has me curious if I am ever going to have an issue. Of course it will be covered under warranty, but its the hassle that "might" come with it.
__________________
Nate, 2012 3500 Cummins-Laramie Loaded. Beige Interior, Molton red. Full DPF/EGR Delete, with 4" Turboback exhaust, H&S Minimax tuner.

Previous....2011 1500 Sport, 2007 1500 Laramie
Reply With Quote
Old 08-04-2012, 12:04 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 12:35 PM.

Internet Brands, Inc.


Contact Details & Emails