Go Back   DodgeForum.com > Dodge Vans & CUVs > Dodge Caravan
Sign in using an external account
Register Forgot Password?


Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!
Sponsored by Dodgetruckparts
Click Here


2002 dodge grand caravan

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-05-2012, 10:57 PM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default 2002 dodge grand caravan

my van keeps ****ting off wen im at stop,i have replaced altanator.plugs,wires,crank sensor,cam sensor ,coil pack and pcm....what else can it be??? please help
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 07-05-2012, 11:24 PM
dsolorio's Avatar
dsolorio dsolorio is offline
Professional
 
Join Date: Jul 2011
Vehicle: 2003 Dodge Durango
Location: Sacramento, Ca
Posts: 193
OblongLight40
Default

What size engine do you have? Have you tried cleaning the IAC and TPS? Can you give more details like, does it idle down then shut off or just stop without warning, does it start right up or trouble, when not in gear is it fine or die as well, when you come to a stop and keep your foot lightly on the gas will it stay on or still shut off? I'm just asking for more detail.
__________________
http://www.mediafire.com/?0fyki7mzixx80

Some people are only alive, simply because its illegal to kill them.
Reply With Quote
  #3  
Old 07-05-2012, 11:28 PM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

3.3 v6 engine,just stops without warning and it starts right away and only dies in gear and i havent tried lightly steping on gas wen im stoped ..how do you clean the IAC and TPS
Reply With Quote
  #4  
Old 07-05-2012, 11:29 PM
master tech's Avatar
master tech master tech is offline
Super Moderator & Tech
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,679
Leonard Pierce
Default

Also adding, is the check engine light on? And does engine stall as so as you put the transmission into gear?
__________________
Dodge Master Tech.
Reply With Quote
  #5  
Old 07-05-2012, 11:31 PM
master tech's Avatar
master tech master tech is offline
Super Moderator & Tech
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,679
Leonard Pierce
Default

I guess we were typing at the same time. It maybe the torque converter in lock up when it shouldn't.
__________________
Dodge Master Tech.
Reply With Quote
  #6  
Old 07-05-2012, 11:36 PM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

no check engine light on and it runs good for a while, it doesnt shut off wen i put it in gear it runs for a while but it has shut off like 10 times today
Reply With Quote
  #7  
Old 07-05-2012, 11:39 PM
master tech's Avatar
master tech master tech is offline
Super Moderator & Tech
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,679
Leonard Pierce
Default

I would see if the dealer can hook up a flight recorder and see it can take snap shot on whats making van to shut off.
__________________
Dodge Master Tech.
Reply With Quote
  #8  
Old 07-05-2012, 11:39 PM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

no rough idle no shaking just shuts off like power cuts off somewhere
Reply With Quote
  #9  
Old 07-05-2012, 11:49 PM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

would a bad TPS or IAC make it shut off?
Reply With Quote
  #10  
Old 07-10-2012, 03:42 AM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

another question..on the cam position sensor do you have to have that gasket on
Reply With Quote
  #11  
Old 07-10-2012, 09:18 AM
master tech's Avatar
master tech master tech is offline
Super Moderator & Tech
 
Join Date: Apr 2007
Vehicle: Mits P/U , Dodge avenger(1996) .
Location: San Bruno ,Ca
Posts: 10,679
Leonard Pierce
Default

Both the cam and crank sensor should have what we called a (cert), thats a piece of cardboard that is glued to the sensor. That adjust the sensor to the air gap that is needed.
__________________
Dodge Master Tech.
Reply With Quote
  #12  
Old 07-11-2012, 12:02 AM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

that is probably why my car is cutting off..both sensors dont have it...going to put them on tomorrow, i will update hopefully that is it because im about to put my caravan on the train tracks...thanks
Reply With Quote
  #13  
Old 07-11-2012, 02:42 PM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

i put both sensor gaskets and same thing..shuts off i dont know if i should keep buying sensors TPS is the only one i havent replaced...going to check my fuel pump and fuel filter next....any more help will very much apriciated
Reply With Quote
  #14  
Old 07-11-2012, 04:20 PM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

new TPS and same crap! van shuts off HELP!!!!!!!
Reply With Quote
  #15  
Old 07-11-2012, 08:42 PM
Cougar41 Cougar41 is offline
Record Breaker
 
Join Date: Feb 2011
Location: SoCal
Posts: 1,884
Default

Are you doing any troubleshooting or are you just guessing and throwing parts at it? Buy a manual and a multimeter. They will save you many headaches and bucks.

Next time it dies check to see if fuel is getting to the fuel rail. There are several ways but one easy one is to spray starter fluid in the intake. If the engine starts and dies, you're not getting fuel. Check for spark at a spark plug. Disconnect a plug wire, hold it close to the engine block then crank the engine. You should see a small spark.You're missing one or the other or possibly timing.
__________________
We took the time to answer your post. Please give us some time and post the fix. You'll help hundreds!

Last edited by Cougar41; 07-11-2012 at 08:48 PM..
Reply With Quote
  #16  
Old 07-12-2012, 01:37 AM
carlitoz carlitoz is offline
Registered User
 
Join Date: May 2012
Posts: 18
Default

well heres my story lol van died about 5 months ago could get spark so i started with crank and cam sensors,coil pack ..some one told me PCM bad so i got that and it started and ran for a while,then my battery was not charging so i tested altenator and it was bad so got a new one, ran for a while then started noticing shut offs every 3 days ,it got worse started shutting off alot and now it wont stay on,today i replaced the TPS and fuel filter and same thing....could it be the fuel pump is going out?? i got spark but now it wont even stay on
Reply With Quote
  #17  
Old 07-12-2012, 03:00 PM
scotter5 scotter5 is offline
Veteran
 
Join Date: Dec 2010
Vehicle: 06 caravan, 3.8,
Location: ft lauderdale, fl area
Posts: 343
Default

I went to dealer today to get a spacer to go on end of camshaft sensor. he looked in computer and said it doesn't exist. he got a new camshaft sensor off shelf and showed me it doesn't have one haynes says it does. went around corner asked mechanic he didn't respond to the question: is there a spacer on the end of sensor. he told me to go ask for a spacer for a CRankshaft sensor.

when installing a camshaft sensor in the port--after pushing it down all the way. did you feel it bottom out??

i did, they didn't have any---i'm from ft lauderdale, fl.
Reply With Quote
Old 07-12-2012, 03:00 PM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 03:58 AM.

Internet Brands, Inc.


Contact Details & Emails