Go Back   DodgeForum.com > Dodge Vans & CUVs > Dodge Journey
Sign in using an external account
Register Forgot Password?


Dodge Journey Dodge Journey forum for discussion on the popular Dodge Crossover and CUV.

Uconnect won't connect

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-01-2012, 12:13 PM
tomsengs tomsengs is offline
Registered User
 
Join Date: Jul 2012
Posts: 2
Default Uconnect won't connect

We bought our Journey new about 6 months ago and about a month later the whole center section of the dash went blank. heater radio and EVERYTHING! 5 trips to the dealer's shop got it working again Well kind of... now the uconnect does not recognise wife's phone and mine wants me to put in the codeand phone will not give me the code. I have been on the phone with Verizon and then Samsung for hours. dodge dealer says too bad go buy a new phone and try that! I say BS..the dealer where we bought the car has not been a whole lot of help either. This might be our last Dodge..
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
Reply With Quote
  #2  
Old 07-01-2012, 05:22 PM
steak59 steak59 is offline
Record Breaker
 
Join Date: Dec 2010
Posts: 1,881
Default

what yr is your journey? U-connect problem is usually a bad U-connect module or software update needed. any waranty left?
If your dealership says the phone is the problem, I bet they someone in the dealership have another phone with blue tooth, right? tell them to show you their phone works, and yours doesn't
Reply With Quote
  #3  
Old 07-02-2012, 07:28 AM
xsdbs xsdbs is offline
Captain
 
Join Date: Jun 2011
Location: Over Here, HI
Posts: 610
Default

1) What is the year of the vehicle?
2) What radio is in the vehicle?
3) When are you being asked for a code? Is it when you are pairing the phone?

Quote:
Originally Posted by tomsengs View Post
We bought our Journey new about 6 months ago and about a month later the whole center section of the dash went blank. heater radio and EVERYTHING! 5 trips to the dealer's shop got it working again Well kind of... now the uconnect does not recognise wife's phone and mine wants me to put in the codeand phone will not give me the code. I have been on the phone with Verizon and then Samsung for hours. dodge dealer says too bad go buy a new phone and try that! I say BS..the dealer where we bought the car has not been a whole lot of help either. This might be our last Dodge..
Reply With Quote
  #4  
Old 07-02-2012, 07:16 PM
tomsengs tomsengs is offline
Registered User
 
Join Date: Jul 2012
Posts: 2
Default U Connect

The Journey is a 2011 we bought it last October. The shop that replaced basically the whole center dash stuff did state their phones work but it does not connect. It finds mine and then it wants the phone code. The phone does not give a code.. Laurie's phone it will not even find..Both phones worked fine before all this happened. It gave a code and we put it in or something like that I don't exactly remember now but it is different how it tries to add the phone now.. Dealer just says go buy a new phone if thatdon't work try another...
Thanks for everything Tom
Reply With Quote
  #5  
Old 07-02-2012, 07:50 PM
bigtsr's Avatar
bigtsr bigtsr is offline
Veteran
 
Join Date: Jun 2006
Location: Burlington.Ontario.Can
Posts: 434
Default

The first thing to do is make sure to delete all pairings
on the Uconnect "settings" menu.
Then make sure both phones have bluetooth turned ON
and are in VISIBLE mode.
Then back to UC setting and pair each phone individually,
the system will ask for a PIN # so use 0000 in example
or 2001.
Watch the phone for response.
Read the pairing section of the DJ owners manual.
__________________
Deep CherryRed 2011 Dodge Journey SXT-Pentastar V6-7 pass.-Uconnect with BlueTooth
-Remote Start-Homelink Burlington,Ontario,CA
Reply With Quote
  #6  
Old 07-02-2012, 08:58 PM
steak59 steak59 is offline
Record Breaker
 
Join Date: Dec 2010
Posts: 1,881
Default

The U-connect is a different computer from the center Stack. For your concern, there should be a Software update for the U-Connect module.
To update the U-Connect module, you have to pull the module out and connect it to a laptop with a USB cable that your dealer should have. It is a bit difficult to do.
If they stated their phone works, tell them to show you.
As for the phone code, every phone has a code, most phone's default code are 0000 as mentioned. But try set it to a different code on your phone first, and try.
Reply With Quote
  #7  
Old 07-03-2012, 07:17 AM
xsdbs xsdbs is offline
Captain
 
Join Date: Jun 2011
Location: Over Here, HI
Posts: 610
Default

Tom, thanks for the information, however you didn't mention the radio model.
1) I would say to reset the Uconnect module by pressing the UC button and say "set up, reset". You'll be told that you will delete pairing of all phones... say yes. Now delete UC from your phone.
2) Now let me explain about the code. Some systems such as Ford sync, when pairing the phone, the radio will display a pin code to enter in the phone. Other systems such as UC will ask you for a 4 digit pin code. Here you'll use an easy to rember set of #'s (as mentioned, such as 0000, 1,2,3,4, {just had to edit that last code, the sight blocked it out?}etc). Now as you go thru your pairing, you'll find Uconnect on your phone when it's searching for devices. Press Uconnect when it is found, now a pop up will appear on the phone asking for the pin code. Here you'll inseert the chosen pin code. The phone and Uconnect will now pair (if they agree with each other and have the handshake), they will go thru a connecting mode and then they will bond. Once they are bonded, then the phone will have a pop up saying there is a request to download your phonebook, select "always & accept". The phonebook will now be downloaded to Uconnect. Depending on how many contacts that you have, this may take a couple minutes. After that, then the phone will be ready to use.
Some older phones have to be put into "discoverable mode" in the phones settings menu or Uconnect won't find them.
3) If you have one of the Mitsubishi radios (RES, REQ, RHB, RBZ) then have you had the Uconnect SW update applied?
4) Has your phone(s) had an update applied to them recently? I have seen where a phone may have been working great and then when a SW update is performed on the phone, it may not work now.
Hope this info helps.


Quote:
Originally Posted by tomsengs View Post
The Journey is a 2011 we bought it last October. The shop that replaced basically the whole center dash stuff did state their phones work but it does not connect. It finds mine and then it wants the phone code. The phone does not give a code.. Laurie's phone it will not even find..Both phones worked fine before all this happened. It gave a code and we put it in or something like that I don't exactly remember now but it is different how it tries to add the phone now.. Dealer just says go buy a new phone if thatdon't work try another...
Thanks for everything Tom
Reply With Quote
  #8  
Old 05-24-2013, 10:43 AM
kimcoffman kimcoffman is offline
New Member
 
Join Date: May 2013
Posts: 1
Default

I have a 2012 Dodge Journey. My UConnect won't connect. It keeps going to the black screen, showing the Dodge logo and then trys to load the safety message. Never fully loads the message and then goes back to a black screen and starts all over again. what is the problem? Is there a reset button somewhere or do we need to take it back to the dealer? Called dealer they said give them $68 to do an upgrade. Is this true or are they just trying to get more money out of us?????
Reply With Quote
  #9  
Old 01-13-2014, 01:42 AM
abnjlmr abnjlmr is offline
New Member
 
Join Date: Jan 2014
Posts: 1
Default

Quote:
Originally Posted by kimcoffman View Post
I have a 2012 Dodge Journey. My UConnect won't connect. It keeps going to the black screen, showing the Dodge logo and then trys to load the safety message. Never fully loads the message and then goes back to a black screen and starts all over again. what is the problem? Is there a reset button somewhere or do we need to take it back to the dealer? Called dealer they said give them $68 to do an upgrade. Is this true or are they just trying to get more money out of us?????
Hi my mom's dodge journey 2012 uconnect has a problem as well. I know that there are about 3 different ways to get into the Bluetooth screen. One way thru the settings, another thru phone-pair phone and audio-Bluetooth. However, everytime we try to go the Bluetooth screen in any way possible, all it does is stay at the same page as if I didn't press any buttons and thats with every other way as well. My mom needs her Bluetooth because its safer to talk on the fone thru the Bluetooth. Please help!!
Reply With Quote
  #10  
Old 03-01-2014, 06:37 PM
chopson32's Avatar
chopson32 chopson32 is offline
Registered User
 
Join Date: Mar 2014
Posts: 6
Default

I've been to the dealer they couldn't figure out why either. Pulled a fuse and it worked again.next day went out again.have to go back again.it's been a month now without it. It's been updated as well.no idea what's up with this system.
Reply With Quote
  #11  
Old 03-03-2014, 07:32 AM
xsdbs xsdbs is offline
Captain
 
Join Date: Jun 2011
Location: Over Here, HI
Posts: 610
Default

what year & model vehicle do you have? Also what radio, phone, what is the SW & Android version in the phone?




Quote:
Originally Posted by chopson32 View Post
I've been to the dealer they couldn't figure out why either. Pulled a fuse and it worked again.next day went out again.have to go back again.it's been a month now without it. It's been updated as well.no idea what's up with this system.
Reply With Quote
  #12  
Old 03-04-2014, 06:41 AM
chopson32's Avatar
chopson32 chopson32 is offline
Registered User
 
Join Date: Mar 2014
Posts: 6
Default

Quote:
Originally Posted by xsdbs View Post
what year & model vehicle do you have? Also what radio, phone, what is the SW & Android version in the phone?
2012 dodge journey avp 4.3 screen. My phone is galaxy s4
Reply With Quote
  #13  
Old 03-04-2014, 02:09 PM
xsdbs xsdbs is offline
Captain
 
Join Date: Jun 2011
Location: Over Here, HI
Posts: 610
Default

Oh, I was hoping to offer some help but I don't have any experience with that radio. But I have heard that the Uconnect module is having issues and doesn't fully reboot when the fuse is pulled. Hopefully the mfg will come out with an update to fix it soon.




Quote:
Originally Posted by chopson32 View Post
2012 dodge journey avp 4.3 screen. My phone is galaxy s4
Reply With Quote
  #14  
Old 03-04-2014, 07:48 PM
bigtsr's Avatar
bigtsr bigtsr is offline
Veteran
 
Join Date: Jun 2006
Location: Burlington.Ontario.Can
Posts: 434
Default

One last thing to try is rebooting TIPM (CanBus)
disconnect the negative from the car battery for
say 5-10 minutes - reconnect and try.
__________________
Deep CherryRed 2011 Dodge Journey SXT-Pentastar V6-7 pass.-Uconnect with BlueTooth
-Remote Start-Homelink Burlington,Ontario,CA
Reply With Quote
  #15  
Old 03-05-2014, 07:27 AM
xsdbs xsdbs is offline
Captain
 
Join Date: Jun 2011
Location: Over Here, HI
Posts: 610
Default

This may work for a short term but I have heard that even that doesn't do a complete reboot of the system and there are some features that still won't work.


Quote:
Originally Posted by bigtsr View Post
One last thing to try is rebooting TIPM (CanBus)
disconnect the negative from the car battery for
say 5-10 minutes - reconnect and try.
Reply With Quote
  #16  
Old 03-06-2014, 07:24 AM
chopson32's Avatar
chopson32 chopson32 is offline
Registered User
 
Join Date: Mar 2014
Posts: 6
Default

Quote:
Originally Posted by xsdbs View Post
This may work for a short term but I have heard that even that doesn't do a complete reboot of the system and there are some features that still won't work.
sounds like dodge hasn't perfected this system well.do what's the solution at dealership?
Reply With Quote
  #17  
Old 03-07-2014, 07:13 AM
xsdbs xsdbs is offline
Captain
 
Join Date: Jun 2011
Location: Over Here, HI
Posts: 610
Default

you're correct about that, they should have done more testing of the system during the pre-build phase before building the vehicle to be sold to the public. I have only heard that the engineers for that supplier company are working on it but I haven't heard when a cure will be available.



Quote:
Originally Posted by chopson32 View Post
sounds like dodge hasn't perfected this system well.do what's the solution at dealership?
Reply With Quote
  #18  
Old 03-25-2014, 03:52 AM
chopson32's Avatar
chopson32 chopson32 is offline
Registered User
 
Join Date: Mar 2014
Posts: 6
Default Uconnect

Quote:
Originally Posted by abnjlmr View Post
Hi my mom's dodge journey 2012 uconnect has a problem as well. I know that there are about 3 different ways to get into the Bluetooth screen. One way thru the settings, another thru phone-pair phone and audio-Bluetooth. However, everytime we try to go the Bluetooth screen in any way possible, all it does is stay at the same page as if I didn't press any buttons and thats with every other way as well. My mom needs her Bluetooth because its safer to talk on the fone thru the Bluetooth. Please help!!
Contact the Chrysler from there main site. Let them know your having same issue.
Reply With Quote
  #19  
Old 01-31-2015, 11:55 AM
cbilbao cbilbao is offline
Registered User
 
Join Date: Jan 2015
Posts: 1
Default rectified?

Quote:
Originally Posted by abnjlmr View Post
Hi my mom's dodge journey 2012 uconnect has a problem as well. I know that there are about 3 different ways to get into the Bluetooth screen. One way thru the settings, another thru phone-pair phone and audio-Bluetooth. However, everytime we try to go the Bluetooth screen in any way possible, all it does is stay at the same page as if I didn't press any buttons and thats with every other way as well. My mom needs her Bluetooth because its safer to talk on the fone thru the Bluetooth. Please help!!
was this rectified? I am having the same issue whereby i go to settings and bluetooth will not accept my command of going further into that menu option. therefore |I cant even pair my device or attempt to. All other setting are fine. help!
Reply With Quote
  #20  
Old 02-01-2015, 09:40 AM
chopson32's Avatar
chopson32 chopson32 is offline
Registered User
 
Join Date: Mar 2014
Posts: 6
Default

Quote:
Originally Posted by cbilbao View Post
was this rectified? I am having the same issue whereby i go to settings and bluetooth will not accept my command of going further into that menu option. therefore |I cant even pair my device or attempt to. All other setting are fine. help!
You have to go to dodge page and click on contact info. It will take you to there contact page and you want to live chat with someone. M-f. You tell them exactly the issue and want ti speak to someone from uconnect, want then ti call you. They will ask if you been to dealer as well. Let them know that i had same issue and dealership had to order me a new bt module was under warranty . This issue nerds to get resolve asap, so be patient and have them talk to dealership. If they need help on trouble shooting this tell them to call my dealership.
Reply With Quote
Old 02-01-2015, 09:40 AM
 
 
 
Reply




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 10:08 AM.

Internet Brands, Inc.


Contact Details & Emails