Go Back  DodgeForum.com > Dodge Cars > Dodge Neon > 1st Gen Neon
Reload this Page >

Turn signals not working correctly

1st Gen Neon 1995 through 1999 Neons

Turn signals not working correctly

  #1  
Old 11-08-2007, 08:03 PM
flyboy03051
flyboy03051 is offline
Registered User
Thread Starter
Join Date: Nov 2007
Posts: 7
Default Turn signals not working correctly

UPDATE:

Second switch has the same symptom. Left turn signal resetsnormally, Right turn signal does not turn off 90% of the time. I don't believe two switches would have the same sympton. The tabs that reset the switch "look" OK but I'm not sure.

Does anyone know if the tabs on the steering colmn are adjustable or how they are replaced ?

Thanks for any help
Bob



************************************************** **
96 Neon - Turn signals not canceling, in either direction.

I replaced the turn signal switch and now the left works normally but the right does not cancel.I putthe orginal switch back in and I am planning to exchange the switch tomorrow. The metal tab on the stering column looks OK. I am hoping I just got a bad switch.

Has anyone else gad these problems ? Is there any adjustments that count cause the problem?

Any help would be appriciated.
 
  #2  
Old 11-09-2007, 10:18 AM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,842
Default RE: Turn signals not working correctly

You could have a problem with the clockspring breaking off the tabs.
 
  #3  
Old 11-09-2007, 04:40 PM
das2123's Avatar
das2123
das2123 is offline
Legend
Join Date: Apr 2006
Location: Spring, TX
Posts: 9,111
Default RE: Turn signals not working correctly

Agreed with the above statement.
 
  #4  
Old 11-20-2007, 07:30 PM
localbroadcast
localbroadcast is offline
Join Date: Nov 2007
Posts: 3
Default RE: Turn signals not working correctly

I have a 95 neon aswell, and from what i've read on the internet this was a common problem. Some people get the turn signal coming on when they press the break, sometimes the signals just stick, n and in my case, when you press the break then put on the left signal, the signal will stay on (not blinking like it should) even after the turn is completed. It's a problem with the electronics inside the signal mechanism, and its pretty simple to fix it. you remove a few panels from around the steering column until you get at the signaling thing, unplug it from the wire harness, and put a new one in. Costs about 40$ for a new one, maybe cheaper if you look thru a junk yard. Personally I took mine apart to see if anything else could have been causing the problem, and just put it back how it was.. It's just an annoyance that I've learned to deal with.. 40$ on a 95 Neon seems like a big investment for me!
 

Thread Tools
Search this Thread
Quick Reply: Turn signals not working correctly


Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: