Go Back   DodgeForum.com > Dodge SUVs > Ramcharger, Trailduster & Power Wagon
Sign in using an external account
Register Forgot Password?


Ramcharger, Trailduster & Power Wagon Grrrr!! Tough Trucks! The Dodge Ramcharger and Plymouth Trailduster were full size SUV's that had good looks and brute strength. The Dodge Power Wagon was comparable to them in toughness, but came in pickup truck form only.

Turn Signals, Hazards, Brake Lights not working

Reply
 
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-26-2009, 11:28 PM
tigerhornet tigerhornet is offline
Registered User
 
Join Date: Jul 2008
Vehicle: 1995 Dodge Ram 1500
Posts: 27
Default Turn Signals, Hazards, Brake Lights not working

My headlights work fine, but the turn signals, hazard lights, and brake lights don't work. when i hit either the hazard light switch or the turn signal switch, absolutely nothing happens, no click, no indicator lights.
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on Dodge Forums!
__________________
Black 1995 Dodge Ram Laramie
5.9L Magnum
Sony CDX-GT510 H/U
Sony 6-1/2" speakers
Sony XM-1252 GTR Amp
Kicker CVT 12" Sub
Reply With Quote
  #2  
Old 04-26-2009, 11:46 PM
BlueBeast2's Avatar
BlueBeast2 BlueBeast2 is offline
Champion
 
Join Date: Jul 2005
Vehicle: 01 Ram 2500, 96 Mustang GT, 94 Mustang GT
Location: Parkesburg, PA
Posts: 2,945
Send a message via AIM to BlueBeast2 Send a message via Yahoo to BlueBeast2
Default

My guess would be the multi-function switch
__________________
2001 Ram 2500,94 Mustang GT www.mysterymachinegt.com,96 Mustang GT
Reply With Quote
  #3  
Old 04-26-2009, 11:48 PM
xray99 xray99 is offline
Banned
 
Join Date: Apr 2009
Vehicle: 1996 1500 SLT
Location: MI USA
Posts: 967
Default

Sounds like you got a wiring gremlin, try changing the flasher fuses yet ?
Reply With Quote
  #4  
Old 07-28-2010, 11:45 AM
n_greenscapes n_greenscapes is offline
Registered User
 
Join Date: Jul 2010
Posts: 1
Default

tigerhornet, did you ever figure out what was wrong with your truck? I have a '97 2500 and the same thing is happening to me. I replaced the multi-function switch and stop lamp switch and nothing happened.
Reply With Quote
  #5  
Old 07-28-2010, 11:55 AM
Maxx_Magnum's Avatar
Maxx_Magnum Maxx_Magnum is offline
Record Breaker
 
Join Date: Jan 2009
Vehicle: 98 Dodge Ram 1500 4X4
Location: NB, Canada
Posts: 2,222
Send a message via MSN to Maxx_Magnum Send a message via Yahoo to Maxx_Magnum
Default

parklight fuse?
__________________

1998 Dodge Ram 1500 4X4 QuadCab 360ci auto
2007 Mazda3 GT 2.3L 5-spd ATX
http://www.youtube.com/user/MaxxMagnum
Reply With Quote
  #6  
Old 07-28-2010, 04:28 PM
2k10HemiRam 2k10HemiRam is offline
Captain
 
Join Date: Jun 2007
Vehicle: 2010 Dodge Ram 1500 Sport
Location: Las Vegas, NV
Posts: 520
Default

I still have a fun issue with my right blinkers, everything works just flashes super fast which sounds annoying, but try replacing the flasher/hazard light replay. The relays changed over the generation but I thing pre-99 the flasher/hazard light relays were two separate round silver relays in the cab relay box. Think it was 99 then combined the two into a single blue square relay. It's only 32 bucks at autozone, gonna pick me one up this weekend after i get paid and see if that fixes that problem.
__________________
2010 1500 Flame Red Sport QC 5.7 Hemi

Build Thread
Reply With Quote
  #7  
Old 10-21-2010, 09:48 PM
dazza5757 dazza5757 is offline
Registered User
 
Join Date: Oct 2010
Posts: 3
Default

Hi I know what your problem is, had the exact same problem, fix is easy your problem is the connection where the light bulb plugs into holder. Take bulbs out and clean plug contacts with a fine flat file, then make sure bulbs are pushed back correctly.
And you problem should be solved. I did this to all 4 front indicator bulbs and been fine since. Darren
Reply With Quote
  #8  
Old 05-12-2011, 12:58 PM
hombre hombre is offline
Registered User
 
Join Date: May 2011
Posts: 1
Default

I have same problem. Cleaned contacts no success
Reply With Quote
  #9  
Old 05-12-2011, 01:03 PM
HeyYou's Avatar
HeyYou HeyYou is online now
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 34,339
Default

do ANY of the rear lights work?
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #10  
Old 12-10-2011, 09:38 AM
SoGone12 SoGone12 is offline
Registered User
 
Join Date: Dec 2011
Posts: 2
Default Any luck guys!?

Is there any update on this problem? I'm having the SAME problem on my 98 Dakota V6. My head lights and tail lights work but NO reverse lights, turns signals on either side/either end, and NO brake lights. I've tried checking fuses, changing the brake light switch under the brake petal, changing the multifunction switch on the steering column and checking the bulbs. I GUESS i'll go through it and check the connections today but it was just weird how they went out one by one. First no Turn signals in front, then in back, then no brake lights (only the third light at the top of the cab), then THAT went out. Seeing as how there's no sound or response when i hit the multifunction switch I'll assume no power is getting there. Thats my target.
Reply With Quote
  #11  
Old 12-10-2011, 10:55 AM
zman17's Avatar
zman17 zman17 is offline
Registered User
Dodge Forum Moderator
 
Join Date: May 2008
Vehicle: 2000 2500HD 4x4 5.9
Location: NH
Posts: 18,729
Default

Seems like a ground problem. Check trailer wiring harness if you have one. Also I suggest buying a Haynes manual. It has wire schematics in it, so you can trace the grounds.
__________________
2000 2500HD 4X4 5.9 and 4:10's,HF tuned SCT,Red-Head gear box, HS 1.7's,
50mm Fastman TB, Hughes Plate,2" Hell Bent ,Volant CAI
Flowmaster 50 series, Rock Solid Ram Steering fix,B&M trans cooler,fuzzy dice good for 5HP
Reply With Quote
  #12  
Old 04-08-2012, 01:15 PM
Mastodon Mastodon is offline
Registered User
 
Join Date: Apr 2012
Posts: 3
Default

Are there any solutions to this problem I am having the EXACT same issue, I have REAR lights that work but that is it, NO Reverse NO Signals NO Brakes, I tested the 5 pin tow package and its getting Brake lights Rear Lights and Reverse but no hazards or signals. Any ideas?
Reply With Quote
  #13  
Old 04-08-2012, 01:19 PM
HeyYou's Avatar
HeyYou HeyYou is online now
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 34,339
Default

Make sure the bulbs are good.... do any of the front lights work? (turn signals/hazards) Also check grounds.
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #14  
Old 04-09-2012, 08:10 AM
SoGone12 SoGone12 is offline
Registered User
 
Join Date: Dec 2011
Posts: 2
Default

Quote:
Originally Posted by Mastodon View Post
Are there any solutions to this problem I am having the EXACT same issue, I have REAR lights that work but that is it, NO Reverse NO Signals NO Brakes, I tested the 5 pin tow package and its getting Brake lights Rear Lights and Reverse but no hazards or signals. Any ideas?
I got my lights to all work by checking the wiring harness behind the wheel well on the drivers side. You don't need to but if you jack it up and take off the drivers side wheel you will see a small trap door panel close to the bottom of the wheel well. Behind it is the harness that connects your rear lighting system. Mine was all frayed and making little to no connections. I have a 1998 Dakota v6 3.9l.
Reply With Quote
  #15  
Old 04-09-2012, 12:31 PM
Mastodon Mastodon is offline
Registered User
 
Join Date: Apr 2012
Posts: 3
Default Still stumped

I tried to follow the wires all the way to the lights, and other than behind the tank I was unable to see any issues. I did notice that my hasard light fuse in the engine compartment fuse box is NOT getting power, good fuse but no power could this explain all of my issues? If so what would you suggest?

So as of now
-NO Turn signals (not even a ticker sound on the dash)
-NO Reverse Lights
-NO Brake Lights

Working
-Headlights
-Tailights
-Trailer Brake Lights
Reply With Quote
  #16  
Old 04-09-2012, 12:36 PM
HeyYou's Avatar
HeyYou HeyYou is online now
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 34,339
Default

Pull the covers off the column, and see if you aren't having some issues in there. If you have tilt wheel, the wires like to pull out of the connector... and things stop working.

Also, you probably have two separate problems there..... (brake/turn, and reverse lights.)
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #17  
Old 04-16-2012, 05:57 PM
Purple97Ram Purple97Ram is offline
Registered User
 
Join Date: Apr 2012
Vehicle: 1997 Dodge Ram 1500 Laramie SLT
Location: Tallahassee, FL
Posts: 4
Default

I am having the same problems on my 97 1500. Third brake light, backup lights, and taillights work but main brake lights, hazards and turn signals don't. All front-end light functions are working. After reading some threads and looking at the diagrams in my Haynes Manuel, I decided to try the multifunction switch, brake switch, and headlight switch from the junk yard with no improvement. I even checked both multifunction switches for continuity and my old one had a problem with #11. I have the factory tow pkg so I thought that might eliminate a hack job but I have not checked the ground. I just sign up here so I am a newbie but I have been trying to read different threads for a while and it seems there could be a few different culprits here.
Reply With Quote
  #18  
Old 04-16-2012, 06:00 PM
Purple97Ram Purple97Ram is offline
Registered User
 
Join Date: Apr 2012
Vehicle: 1997 Dodge Ram 1500 Laramie SLT
Location: Tallahassee, FL
Posts: 4
Default

Also, when I tilted the wheel all the way down to take off the shrouds it stuck there, anyone know how to unstick it? Do I have to take off the ignition switch? I did the same thing to the 95 1500 in the junk yard, oops.
Reply With Quote
  #19  
Old 04-16-2012, 06:45 PM
HeyYou's Avatar
HeyYou HeyYou is online now
Section Moderator
Dodge Forum Moderator
 
Join Date: Apr 2010
Vehicle: 1996 Dodge Ram 2500
Location: Adrian, MI
Posts: 34,339
Default

Stuck there? As in, won't turn, or, you can't tilt it back up?? Should be able to just pull the release lever, and it should come right back up..... should....

Check where the trailer harness hits the rear harness.... (trace if from the plug back to find where they link.) Known problem area on these trucks.
__________________
1996 Ram 2500 5.9 EC/SB Gas, Auto, 4x4, Hughes plenum plate, Kegger mod, double roller timing set, rest is stock. For now.....
Reply With Quote
  #20  
Old 04-17-2012, 05:22 PM
Purple97Ram Purple97Ram is offline
Registered User
 
Join Date: Apr 2012
Vehicle: 1997 Dodge Ram 1500 Laramie SLT
Location: Tallahassee, FL
Posts: 4
Default

Yea, it turns fine it is just stuck in the down position. I can move the tilt lever but it does not want to release. The funny thing is the fact I did the same thing to the one in the junkyard. If it hadn't started raining I would have experimented with it a while.

I'll check out the harness when I can this week and post what I find. Thanks!
Reply With Quote
Old 04-17-2012, 05:22 PM
 
 
 
Reply




Tags
2000, 2001, 94, blinkers, brake, caravan, dodge, flasher, gt, hazard, lights, mustang, signal, signals, sprinter, turn, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join DodgeForum
Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -4. The time now is 08:39 AM.

Internet Brands, Inc.


Contact Details & Emails