P0734 Only in overdrive - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Dakota > 2nd Gen Dakota Tech
Reload this Page >

P0734 Only in overdrive

2nd Gen Dakota Tech 1997 - 2004 Dodge Dakota Tech - The ultimate forum for technical help on the 2nd Gen Dakota.

P0734 Only in overdrive

  #1  
Old 01-07-2019, 08:03 PM
Physkomere
Physkomere is offline
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 18
Default P0734 Only in overdrive

2002 Dakota Sport 4.7 45rfe 270k miles
Only in OD it Started acting like it was going into neutral when above 45/50 mph and if going up hills the Rpm would bounce up and down a few hundred. If it acts like itís in neutral it will jerk hard back into gear. And if it does it so many times it goes limp and throws a p0734. But if I clear it and turn OD off it switches all gears smooth. Ive changed fluid and filters and it was reddish colored like normal but had an odd smell to it. Changing fluids did not alter anything and it still does it. Valve body and accumulator plate doesnít seem to have any damage. And no shreds of metal. There was a fine metal powder on the magnet but I figured this was normal? Something electrical? Something mechanical? If any more info needed let me know please and thanks.
 
  #2  
Old 01-08-2019, 12:59 AM
magnethead
magnethead is offline
Grand Champion
Join Date: Feb 2005
Location: Fort Worth, TX
Posts: 6,527
Default

OD-Off should only disable fourth and Fifth gear. I don't have an FSM handy that includes the 5th gear TCM flash programming. I think it also forces second prime instead of regular second, but not positive on that.

Originally Posted by FSM Page 21-514
OPERATION
At key-on, overdrive operation is allowed. Pressing

the switch once causes the overdrive OFF mode to be entered and the overdrive OFF switch lamp to be illuminated. Pressing the switch a second time causes normal overdrive operation to be restored and the overdrive lamp to be turned off. The overdrive OFF mode defaults to ON after the ignition switch is cycled OFF and ON. The normal position for the con- trol switch is the ON position. The switch must be in this position to energize the solenoid and allow a 3-4 upshift. The control switch indicator light illuminates only when the overdrive switch is turned to the OFF position, or when illuminated by the transmission control module.







 

Last edited by magnethead; 01-08-2019 at 01:02 AM.
  #3  
Old 01-08-2019, 11:20 AM
Physkomere
Physkomere is offline
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 18
Default

So should I start looking at a rebuild or remanufactured transmission?
 
  #4  
Old 01-08-2019, 03:16 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 55,557
Default

Have you done any work to the trans previously? Changed gears, or tire size? That code is whining about incorrect gear ratio........ which is just odd. Slipping clutches???
 
  #5  
Old 01-08-2019, 04:03 PM
Physkomere
Physkomere is offline
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 18
Default

No, the only things Iíve done to this truck are alternator, control arms, and a dual exhaust. As well as routine maintenance. Everything else is stock. Like I said though in drive It goes 1-2 2-3 3-what feels like neutral. Then jerks hard to 3rd again I assume. Then all the way back to 2nd in limp mode after 3 or so attempts. But if overdrive is turned off with the button I have no jerking or anything.
 
  #6  
Old 01-08-2019, 08:09 PM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 55,557
Default

Then either the O/D solenoid is bad, sticks, or something else is jammed up somewhere. If it just freewheels in what should be O/D, that would explain the code...... No clue how to diagnose that one.....
 
  #7  
Old 01-08-2019, 11:07 PM
magnethead
magnethead is offline
Grand Champion
Join Date: Feb 2005
Location: Fort Worth, TX
Posts: 6,527
Default

Since Third and Limp are functional, that rules out the overdrive solenoid in a sense (or so I'd think). I'd be looking more at the 4C solenoid. I don't know if there is a way to force second prime to test the 4C clutch.
 
  #8  
Old 01-09-2019, 09:31 AM
Physkomere
Physkomere is offline
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 18
Default

Iíll try to take a video of what it does when I get off of work this evening.
 
  #9  
Old 01-09-2019, 02:30 PM
Physkomere
Physkomere is offline
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 18
Default

I also forgot to mention, when I changed filters and replaced fluids, I got a p0871 if I recall correctly. But I cleared it and added more fluid since it was a little low and It hasnít come back.
 
  #10  
Old 01-09-2019, 07:47 PM
Physkomere
Physkomere is offline
Registered User
Thread Starter
Join Date: Mar 2018
Posts: 18
Default

hereís a video of what it does. Kind of a bad video but it works.
 

Thread Tools
Search this Thread
Quick Reply: P0734 Only in overdrive


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: