Power Locks, ESP, HVAC Controls not working - Page 6 - DodgeForum.com

Go Back  DodgeForum.com > Dodge Trucks > Dodge Ram > 4th Gen Ram Tech
Reload this Page >

Power Locks, ESP, HVAC Controls not working

4th Gen Ram Tech 2009 - 2018 Rams and the 2019 Ram Classic: This section is for TECHNICAL discussions only, that involve the 2009 - 2018 Rams and the 2019 Ram Classic. For any non-tech discussions, please direct your attention to the "General discussion/NON-tech" sub sections.

Power Locks, ESP, HVAC Controls not working

  #51  
Old 06-23-2017, 11:22 PM
Tad Griffin
Tad Griffin is offline
Registered User
Join Date: Jun 2017
Posts: 1
Default

I too have a 2009 1500 hemi 4x4 4 door and it acted up a couple years ago, bas, abs, airbag, no rear windows, no blower, horn, etc.... I put some pressure on the back side of the tipm, and it went away, so I stuck a piece of rubber in beside the box, and was good for 2 years.... today, it decided to give out. I did get it to work a couple times while out by putting more pressure on it, but finally even that isn't working. I now have the tipm out here on my shop floor, not really knowing what I'm looking at, and the truck is down until I figure it out.
Is there any good news on this issue??
Thanks for ANY help.
 

Last edited by Tad Griffin; 06-23-2017 at 11:24 PM.
  #52  
Old 06-24-2017, 10:27 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 55,557
Default

I would suspect you need to replace the TIPM.
 
  #53  
Old 06-24-2017, 01:30 PM
Pedro Dog
Pedro Dog is offline
Record Breaker
Join Date: Jan 2010
Location: San Pedro, California
Posts: 1,341
Default

Originally Posted by Tad Griffin View Post
I put some pressure on the back side of the tipm, and it went away
If pressure was "fixing it", then maybe you have cracked solder joints somewhere. Get a magnifying lens and take a careful look around. You may get lucky and find one. To fix cracked solder joints, just re flow the solder.
 
  #54  
Old 08-07-2017, 04:26 PM
overtorqued
overtorqued is offline
Registered User
Join Date: Jan 2014
Location: NW Ohio
Posts: 16
Default

I knew I shouldn't have said anything... was driving home from work and about a mile away from home the wipers started, all of the lights on the dash lit up, blower stopped and just as fast it all came back. Just put in TIPM number 4. Number 3 lasted around 2.5 years. The good news is it's a brand new part, not refurbished. I was told they are manufacturing new parts again so I jumped on one rather than fooling around. I'm just looking for a dependable fix. No programming required. There were 2 fuses not populated in the new part (have bright colored circles around them) causing the seat belt and air bag lights to stay lit. Moved the fuses from the old one and all is well.
 
  #55  
Old 12-05-2018, 07:28 PM
5.7
5.7 is offline
Registered User
Join Date: Dec 2018
Posts: 1
Default Same Issue!

Having the exact same issues as stated above! Started happening yesterday, I got off work and went out to start up my truck (2010 Ram 1500 SLT) ESP BAS/traction control/SVC4WD/air bag light all came on out of the blue. No heat, no wipers, no power locks, and no control over rear windows from controls on driver door panel. Stayed on the whole way home, until I got to my driveway and all warning lights suddenly go off and everything started working as normal. Woke up this morning to start my truck hoping it was just a random glitch the day before, yet, it happened again. So, I went ahead and drove to work, halfway there, warning lights went off and everything started working as normal again. Got off work again today, and same exact issue. Really starting to frustrate me, seeing Iíve only had the truck 4 weeks. Iím hoping it isnít the TIPM, Iíve read other forums stating that they had issues with wheel speed sensors and such. Even though I bought an extended warranty with my truck, I really donít want to fork out a lot of money!
 
  #56  
Old 12-06-2018, 09:15 AM
HeyYou's Avatar
HeyYou
HeyYou is offline
Super Moderator
Join Date: Apr 2010
Location: Clayton MI
Posts: 55,557
Default

If you have only had it a month, time to go back and have a chat with the folks you bought it from.
 

Thread Tools
Search this Thread
Quick Reply: Power Locks, ESP, HVAC Controls not working


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: