Go Back  DodgeForum.com > Dodge Cars > Dodge Caliber
Reload this Page >

limp mode pain in the butt

Dodge Caliber The new sporty Dodge Caliber is a hatchback that replaces the Dodge Neon. The Dodge Caliber is here to stay!

limp mode pain in the butt

  #1  
Old 07-24-2014, 09:04 PM
pat4life69
pat4life69 is offline
Registered User
Thread Starter
Join Date: Jul 2014
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default limp mode pain in the butt

Okay this is the symptoms I have. The car is stuck in limp mode. The first time it happened it was stuck that way for like a week or so. The second time a few days. This time it's been this way for about a month. I can not hunt the problem. I've been told it was the throttle body but with the way it is now I'm not sure that's it. Right now it start with the ETC light on. There is a 2-3 second delay between turning the key and the car turning over. I'm starting to think it's an electrical problem. Any help would be appreciated. ALSO PLEASE DON'T HIJACK MY THREAD!! Thanks all
 
  #2  
Old 07-28-2014, 09:05 PM
pat4life69
pat4life69 is offline
Registered User
Thread Starter
Join Date: Jul 2014
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

No help here I take it?
 
  #3  
Old 07-28-2014, 11:55 PM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,842
Likes: 0
Received 0 Likes on 0 Posts
Default

Have you check the IOD fuse in the PDC center. That's where the fuses are located. You also need to scan the modules for active or stored codes. Do you know the codes that vehicle is storing?
 
  #4  
Old 07-29-2014, 07:33 AM
pat4life69
pat4life69 is offline
Registered User
Thread Starter
Join Date: Jul 2014
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

From what I've read so far the IOD fuse does!the same thing as disconnecting the battery, which I've done multiple time. There was 2 codes that came up. These were EVAP codes. Would cause little to no problem in drivability other than less miles per gallon. today I've found when cold starting it the ETC light comes on. I let it warm to about half of normal then turned it off then back on. The ETC light goes off but it stays in limp mode. Although I've lost 40 pounds sense is been stuck in limp mode it is very annoying not to have transportation when you're still paying on it. I'll try the IOD fuse. Can you tell me what number it is?
 
  #5  
Old 07-30-2014, 11:58 PM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,842
Likes: 0
Received 0 Likes on 0 Posts
Default

Do you know what the other code is? Maybe short runner valve?
 
  #6  
Old 07-31-2014, 06:34 AM
pat4life69
pat4life69 is offline
Registered User
Thread Starter
Join Date: Jul 2014
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

They were both EVAP codes
 
  #7  
Old 07-31-2014, 11:58 PM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,842
Likes: 0
Received 0 Likes on 0 Posts
Default

Okay, Did you do a Electric Throttle Control relearn? (ETC) You need a scanner so you can perform the relearn.
 
  #8  
Old 08-01-2014, 09:30 PM
pat4life69
pat4life69 is offline
Registered User
Thread Starter
Join Date: Jul 2014
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

Ok I performed a relearn procedure I found online that did nothing. I then connected my code reader and went through the diagnostics. This is what was read:
MIL - OFF
MISFIRE - READY
FUEL - READY
CCM - READY
CAT - NOT READY
HCM - N/A
EVAP - NOT READY
2AIR - N/A
A/C - N/A
O2S - NOT READY
HO2S - READY
EGR - NOT READY

I really hope this helps me in finding out this problem. Thank you all.
 
  #9  
Old 08-05-2014, 03:42 AM
pat4life69
pat4life69 is offline
Registered User
Thread Starter
Join Date: Jul 2014
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

I guess this didn't help?
 
  #10  
Old 08-09-2014, 09:26 PM
lxman1's Avatar
lxman1
lxman1 is offline
Site Moderator
Dodge Forum Moderator
Join Date: May 2008
Location: Louisville, Ky
Posts: 9,499
Received 0 Likes on 0 Posts
Default

That all looks normal. The not ready means that it isn't up to normal operating temp when the the test was ran.
 

Thread Tools
Search this Thread
Quick Reply: limp mode pain in the butt


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: