Go Back  DodgeForum.com > Dodge Vans & CUVs > Dodge Caravan
Reload this Page >

A670 (31TH) Transmission Help

Dodge Caravan The Dodge Caravan is the best selling mini van from Dodge. How many Dodge Caravan owners here at DodgeForum.com would agree? Discuss it now!

A670 (31TH) Transmission Help

  #1  
Old 01-04-2012, 01:46 AM
Iwagner
Iwagner is offline
Registered User
Thread Starter
Join Date: Nov 2011
Posts: 17
Smile A670 (31TH) Transmission Help

Hi,

I have a 1998 Grand Caravan with a 3.0L and 3 Speed Transmission that just started slipping today (from a stop) and also not shifting from 1st to 2nd until RPM's are substantially higher than whats "normal" for it.

Any ideas on where to start? DIY Rebuild, Fluid & Filter Change, or Re-manufactured??

Here's the stats: 174,500 miles. Transmission was rebuilt at 58,000 (now has 116,500) on it. I performed flush, filter and fluid change 11,000 miles ago. No shavings inside pan.

Any help would be appreciated. Thanks - Ian
 
  #2  
Old 01-04-2012, 08:14 AM
TurboStixx's Avatar
TurboStixx
TurboStixx is offline
Captain
Join Date: Oct 2011
Location: Richmond, Virginia
Posts: 646
Default

Check TV cable and make adjustments if needed

Any Codes? With the 1st-2nd not shifting until HIGH RPMs, and slipping when in first, I have an inkling that it may be your shift solenoid.

The resident transmission expert around here though is Master Tech, I would PM him and tell him what is going on, I am sure he can help you (He floats around the van section alot)
 
  #3  
Old 01-04-2012, 10:52 AM
bjr1a
bjr1a is offline
Professional
Join Date: Jan 2011
Posts: 201
Default

DOes the trans completely disengage at a stop and when you press the gas pedal it re-applys?
 
  #4  
Old 01-04-2012, 04:39 PM
Iwagner
Iwagner is offline
Registered User
Thread Starter
Join Date: Nov 2011
Posts: 17
Default

Originally Posted by TurboStixx View Post
Check TV cable and make adjustments if needed

Any Codes? With the 1st-2nd not shifting until HIGH RPMs, and slipping when in first, I have an inkling that it may be your shift solenoid.

The resident transmission expert around here though is Master Tech, I would PM him and tell him what is going on, I am sure he can help you (He floats around the van section alot)
Thanks for the suggestions. No codes from the transmission. I lubed and adjusted the TV cable with no improvements. After road testing I found that it's not a slipping issue, just a shifting issue. The transmission does not downshift from 2nd to 1st when coming to a stop, so you start driving in 2nd instead of 1st! When stopped, if you manually shift the transmission through the gears it will engage 1st and drive normally. So, to recap:

1. When in Drive, transmission doesn't downshift from 2nd to 1st
2. When in 1st, transmission is "late" to upshift to 2nd (21-22mph instead of 11-14mph)

Any other suggestions?? I bought the factory manual and the ATSG transmission manual that I'd like to make available to the forum. I'll host the files, feel free to repost the links or make it a sticky. Thanks!

1998 Caravan Factory Service Manual: https://docs.google.com/open?id=0Bwb...Q5NWM2OTRkY2U4
ATSG A404 thru A670 Transmission Manual: https://docs.google.com/open?id=0Bwb...Y4NTY2MmRkZWQ4
 

Last edited by Iwagner; 01-04-2012 at 04:42 PM.
  #5  
Old 01-04-2012, 05:47 PM
TurboStixx's Avatar
TurboStixx
TurboStixx is offline
Captain
Join Date: Oct 2011
Location: Richmond, Virginia
Posts: 646
Default

I would check the fluid, i know stupid thing, but that has totally screwed me before, if thats not it and your transmission is still slipping, i would have to say the transmission speed sensor or the 1st-2nd shift solenoid.

Like i said, master tech is the local dodge chrysler guy, i am sure he will be on soon and be able to give you a little more info, i am not 100% on your trans.
 
  #6  
Old 01-04-2012, 06:15 PM
Iwagner
Iwagner is offline
Registered User
Thread Starter
Join Date: Nov 2011
Posts: 17
Default

Lol, I thought the same thing - fluid is good. I'll PM master tech. Thanks!
 
  #7  
Old 01-05-2012, 12:14 AM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,842
Default

Got your message. I have been a little busy fixxing the new penastar motors. I send you a message and I believe yo have governor valves sticking. This was a common problem back in the day. On the 31TH transmission. The other common problem was the kick down lever would sized and could the transmission shift lever to move into neutral.
 
  #8  
Old 01-05-2012, 08:50 AM
TurboStixx's Avatar
TurboStixx
TurboStixx is offline
Captain
Join Date: Oct 2011
Location: Richmond, Virginia
Posts: 646
Default

theres master tech, I would do what he says lol, don't listen to me!
 
  #9  
Old 01-05-2012, 06:04 PM
Iwagner
Iwagner is offline
Registered User
Thread Starter
Join Date: Nov 2011
Posts: 17
Default

Thanks for the info! I read up on the governor valves last night, doesn't seem like too difficult of a job or too expensive either. Just for confirmation - is it the governor plugs or valves (see attached photos) Thanks!


 

Last edited by Iwagner; 01-05-2012 at 06:06 PM.
  #10  
Old 01-07-2012, 11:43 PM
master tech's Avatar
master tech
master tech is offline
Site Moderator & Tech
Dodge Forum Moderator
Join Date: Apr 2007
Location: San Bruno ,Ca
Posts: 10,842
Default

Yes,That is correct. The lower picture. The valve body needs to be removed to replace the governor body and valves. The three bolts for the governor have a 7mm bolt head.
 

Thread Tools
Search this Thread
Quick Reply: A670 (31TH) Transmission Help


Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.